summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Booker2022-09-24 18:40:01 +1200
committerThomas Booker2022-09-24 18:40:01 +1200
commite15e82403981813c1a2c8e0c2d88cc1cadb3d2e0 (patch)
tree8fafbe6380235136f6bd371fbd5299177f7669f8
parent1ba21e95f4d0fc532d82097a6f9ef6efe712a23e (diff)
downloadaur-e15e82403981813c1a2c8e0c2d88cc1cadb3d2e0.tar.gz
Added pam file to make auth work
-rw-r--r--PKGBUILD13
-rw-r--r--pam_phosh5
2 files changed, 16 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 88b3a6b26799..b8a6bb113b9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -33,8 +33,14 @@ makedepends=(
)
provides=(phosh)
conflicts=(phosh)
-source=("git+${url}.git")
-sha256sums=('SKIP')
+source=(
+ "git+${url}.git"
+ "pam_phosh"
+)
+sha256sums=(
+ 'SKIP'
+ 'b7793f80c533e84ad8adfe8bb46c69f107575e724aa9b53b41f370baa37e4fd5'
+ )
pkgver() {
cd phosh
@@ -56,4 +62,7 @@ build() {
package() {
DESTDIR="${pkgdir}" meson install -C _build
+
+ install -Dm644 "$srcdir"/pam_phosh \
+ "$pkgdir"/etc/pam.d/phosh
}
diff --git a/pam_phosh b/pam_phosh
new file mode 100644
index 000000000000..0580d9841cef
--- /dev/null
+++ b/pam_phosh
@@ -0,0 +1,5 @@
+#%PAM-1.0
+
+auth include system-local-login
+account include system-local-login
+session include system-local-login