summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2020-07-01 20:45:44 +0200
committerPhilip Goto2020-07-01 20:45:44 +0200
commite2832ebfe920cdbaa8599eddc3a6e2a5dbfcf730 (patch)
treec20b199a7842817a23c3c3a097a5ffd6366c70e3
parent4ea6416bb9f7b98fd5cbfbef902a1b0c260053e3 (diff)
downloadaur-e2832ebfe920cdbaa8599eddc3a6e2a5dbfcf730.tar.gz
Update to versioned pkgbuild
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
2 files changed, 8 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b8c7db01753..af0dd82a944f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,20 @@
pkgbase = phosh-git
pkgdesc = A pure Wayland shell prototype for GNOME on mobile devices
- pkgver = 0.2.0.r3.g1e65b98
+ pkgver = 0.4.0.r6.ga9825bd
pkgrel = 1
url = https://source.puri.sm/Librem5/phosh
arch = i686
arch = x86_64
- arch = armv6h
arch = armv7h
+ arch = aarch64
license = GPL3
makedepends = ctags
makedepends = git
makedepends = meson
makedepends = vala
depends = feedbackd
- depends = gcr
- depends = gnome-desktop
depends = libhandy
- depends = libnm
- depends = libpulse
- depends = libsecret
depends = phoc
- depends = upower
provides = phosh
conflicts = phosh
source = git+https://source.puri.sm/Librem5/phosh.git
diff --git a/PKGBUILD b/PKGBUILD
index ebf6d7d25a5a..fa6a76254b3c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,15 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
pkgname=phosh-git
-pkgver=0.2.0.r3.g1e65b98
+pkgver=0.4.0.r6.ga9825bd
pkgrel=1
pkgdesc="A pure Wayland shell prototype for GNOME on mobile devices"
url="https://source.puri.sm/Librem5/phosh"
license=("GPL3")
-arch=(i686 x86_64 armv6h armv7h)
+arch=(i686 x86_64 armv7h aarch64)
depends=('feedbackd'
- 'gcr'
- 'gnome-desktop'
'libhandy'
- 'libnm'
- 'libpulse'
- 'libsecret'
- 'phoc'
- 'upower')
+ 'phoc')
makedepends=('ctags'
'git'
'meson'
@@ -41,14 +35,14 @@ prepare() {
}
build() {
- arch-meson phosh build
+ arch-meson phosh build # -Dtests=false
ninja -C build
}
# check() {
-# ninja -C build test
+# meson test -C build --print-errorlogs
# }
package() {
- DESTDIR="${pkgdir}" ninja -C build install
+ DESTDIR="${pkgdir}" meson install -C build
}