summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2021-01-07 13:36:38 +0100
committerPhilip Goto2021-01-07 13:36:38 +0100
commitf0534cbab36dead4c363e9e5380e104ad0c026ad (patch)
treead6eee472635ed80ab0c0b92d76599d36f7bb5f8
parente2832ebfe920cdbaa8599eddc3a6e2a5dbfcf730 (diff)
downloadaur-f0534cbab36dead4c363e9e5380e104ad0c026ad.tar.gz
Refactor pkgbuild
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD51
2 files changed, 30 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af0dd82a944f..261c5e958e1c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = phosh-git
pkgdesc = A pure Wayland shell prototype for GNOME on mobile devices
- pkgver = 0.4.0.r6.ga9825bd
+ pkgver = 0.7.1.r13.g0ca4ab1
pkgrel = 1
url = https://source.puri.sm/Librem5/phosh
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index fa6a76254b3c..705e5a4d6af9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,55 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
pkgname=phosh-git
-pkgver=0.4.0.r6.ga9825bd
+pkgver=0.7.1.r13.g0ca4ab1
pkgrel=1
pkgdesc="A pure Wayland shell prototype for GNOME on mobile devices"
url="https://source.puri.sm/Librem5/phosh"
license=("GPL3")
arch=(i686 x86_64 armv7h aarch64)
-depends=('feedbackd'
- 'libhandy'
- 'phoc')
-makedepends=('ctags'
- 'git'
- 'meson'
- 'vala')
+depends=(
+ 'feedbackd'
+ 'libhandy'
+ 'phoc'
+)
+makedepends=(
+ 'ctags'
+ 'git'
+ 'meson'
+ 'vala'
+)
provides=(phosh)
conflicts=(phosh)
-source=("git+https://source.puri.sm/Librem5/phosh.git"
- "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git")
-sha256sums=("SKIP"
- "SKIP")
+source=(
+ "git+https://source.puri.sm/Librem5/phosh.git"
+ "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
+)
+sha256sums=('SKIP' 'SKIP')
pkgver() {
- cd phosh
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd phosh
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd phosh
+ cd phosh
- git submodule init
- git config --local submodule.subprojects/gvc.url "$srcdir/libgnome-volume-control"
- git submodule update
+ git submodule init
+ git config --local submodule.subprojects/gvc.url "$srcdir/libgnome-volume-control"
+ git submodule update
}
build() {
- arch-meson phosh build # -Dtests=false
- ninja -C build
+ arch-meson phosh build
+ meson compile -C build
}
# check() {
-# meson test -C build --print-errorlogs
+# dbus-run-session xvfb-run \
+# -s '-screen 0 1920x1080x24 -nolisten local' \
+# meson test -C build --print-errorlogs
# }
package() {
- DESTDIR="${pkgdir}" meson install -C build
+ DESTDIR="${pkgdir}" meson install -C build
}