summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph Carta2020-02-01 21:45:51 -0500
committerJoseph Carta2020-02-01 21:45:51 -0500
commit0e1ebc7403def934c3cb656782e0a58c090af6f6 (patch)
treefce803857fc9091a71723e4ac7fa572f5ae204ee
parentcbe576f543ad419f8e0cf745538cebde48a6ab52 (diff)
downloadaur-0e1ebc7403def934c3cb656782e0a58c090af6f6.tar.gz
Updated to use python3.8
-rw-r--r--.SRCINFO11
-rw-r--r--ActionI18N.patch10
-rw-r--r--PKGBUILD11
3 files changed, 20 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e61ee4702c7..0c740842df39 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = photofilmstrip
pkgdesc = Create video clips from photos
pkgver = 3.7.2
- pkgrel = 2
+ pkgrel = 3
url = http://www.photofilmstrip.org/en/
arch = i686
arch = x86_64
license = GPL2
- depends = python37
- depends = python37-pillow
- depends = python37-wxpython
- depends = python37-gobject
- depends = python37-six
+ depends = python
+ depends = python-pillow
+ depends = python-wxpython
+ depends = python-sphinx
depends = gst-python
optdepends = gst-plugins-bad: additional rendering formats
optdepends = gst-plugins-good: additional rendering formats
diff --git a/ActionI18N.patch b/ActionI18N.patch
new file mode 100644
index 000000000000..401a2e68b9e7
--- /dev/null
+++ b/ActionI18N.patch
@@ -0,0 +1,10 @@
+--- src/PFS-3.7.2/photofilmstrip/action/ActionI18N.py 2019-11-03 12:09:55.000000000 -0500
++++ ActionI18N.py 2020-02-01 21:02:16.332900668 -0500
+@@ -40,6 +40,6 @@
+ lang = gettext.translation(Constants.APP_NAME,
+ localeDir,
+ languages=[curLang, "en"])
+- lang.install(True)
++ lang.install()
+ except IOError:
+ gettext.install(Constants.APP_NAME)
diff --git a/PKGBUILD b/PKGBUILD
index dfa6fc10cbf4..42291ec6c188 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
# Contributor: Carlos Henrique Merces Moreira "chmercesmoreira" <ch.mercesmoreira@gmail.com>
pkgname=photofilmstrip
pkgver=3.7.2
-pkgrel=2
+pkgrel=3
pkgdesc="Create video clips from photos"
arch=('i686' 'x86_64')
url="http://www.photofilmstrip.org/en/"
license=('GPL2')
-depends=('python37' 'python37-pillow' 'python37-wxpython' 'python37-gobject' 'python37-six' 'gst-python')
+depends=('python' 'python-pillow' 'python-wxpython' 'python-sphinx' 'gst-python')
optdepends=('gst-plugins-bad: additional rendering formats'
'gst-plugins-good: additional rendering formats'
'gst-plugins-ugly: additional rendering formats'
@@ -17,16 +17,15 @@ md5sums=('a7b4362b9eb8ede7a4ee99f0165f383a')
build() {
cd "$srcdir/PFS-$pkgver"
- python3.7 setup.py build
+ python setup.py build
}
package () {
cd "$srcdir/PFS-$pkgver"
- python3.7 setup.py install --root="$pkgdir" --optimize=1
+ patch photofilmstrip/action/ActionI18N.py ../../ActionI18N.patch
+ python setup.py install --root="$pkgdir" --optimize=1
chmod 644 "$pkgdir/usr/share/applications/photofilmstrip.desktop"
- mkdir "$pkgdir"/usr/share/doc/photofilmstrip/html
- cp -r ../../*.html "$pkgdir"/usr/share/doc/photofilmstrip/html
find "$pkgdir/usr/share/doc/photofilmstrip/" -type f -exec chmod 644 {} \;
for size in 32x32 48x48 64x64 192x192