summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-01-28 20:03:38 -0500
committeracxz2020-01-28 20:03:38 -0500
commit5110cd8ca9b8221558e47fd65002802d6f30e1d8 (patch)
treebb3feb8c458c62769da8ddd9f4d37f647eb59967
downloadaur-5110cd8ca9b8221558e47fd65002802d6f30e1d8.tar.gz
create photofilmstrip-git package
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD43
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b392679cf594
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = photofilmstrip-git
+ pkgdesc = Create video clips from photos
+ pkgver = r641.e7fbf5d
+ pkgrel = 1
+ url = http://www.photofilmstrip.org/en/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = python
+ makedepends = python-setuptools
+ depends = python
+ depends = python-wxpython
+ depends = python-pillow
+ depends = gst-python
+ optdepends = gst-plugins-bad: additional rendering formats
+ optdepends = gst-plugins-good: additional rendering formats
+ optdepends = gst-plugins-ugly: additional rendering formats
+ optdepends = gst-libav: additional rendering formats
+ provides = photofilmstrip
+ conflicts = photofilmstrip
+ source = git+https://github.com/PhotoFilmStrip/PFS
+ md5sums = SKIP
+
+pkgname = photofilmstrip-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..374ca4be596b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+pkgname=photofilmstrip-git
+pkgver=r641.e7fbf5d
+pkgrel=1
+pkgdesc="Create video clips from photos"
+arch=('i686' 'x86_64')
+url="http://www.photofilmstrip.org/en/"
+license=('GPL2')
+depends=('python' 'python-wxpython' 'python-pillow' 'gst-python')
+makedepends=('python' 'python-setuptools')
+optdepends=('gst-plugins-bad: additional rendering formats'
+ 'gst-plugins-good: additional rendering formats'
+ 'gst-plugins-ugly: additional rendering formats'
+ 'gst-libav: additional rendering formats')
+_pkgname=PFS
+provides=('photofilmstrip')
+conflicts=('photofilmstrip')
+source=("git+https://github.com/PhotoFilmStrip/PFS")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ python setup.py build
+}
+
+package () {
+ cd "$srcdir/$_pkgname"
+ python setup.py install --root="$pkgdir" --optimize=1
+
+ chmod 644 "$pkgdir/usr/share/applications/photofilmstrip.desktop"
+
+ find "$pkgdir/usr/share/doc/photofilmstrip/" -type f -exec chmod 644 {} \;
+
+ for size in 32x32 48x48 64x64 192x192
+ do
+ chmod 644 "$pkgdir/usr/share/icons/hicolor/$size/apps/photofilmstrip.png"
+ done
+}