summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commitcd63853107db01db4711a95aa4db0901d8f94854 (patch)
tree1a220127bfbb931f33f1c2173c1ec95347a5cdb6
downloadaur-cd63853107db01db4711a95aa4db0901d8f94854.tar.gz
Initial PKGBUILD status as of 28.11.2014
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e62fb2b3075b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = photomolo
+ pkgdesc = Frontend to manage connections to remote filesystems using GIO/GVFS
+ pkgver = 1.2.4
+ pkgrel = 1
+ url = http://www.nic.funet.fi/pub/sci/graphics/packages/photomolo/photomolo.html
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = libjpeg-turbo
+ source = http://www.nic.funet.fi/pub/sci/graphics/packages/photomolo/photomolo-1.2.4.tar.gz
+ md5sums = 8e277b95023b2e32171edeae5367e7f5
+
+pkgname = photomolo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed8f1f2847e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+
+pkgname=photomolo
+pkgver=1.2.4
+pkgrel=1
+pkgdesc="Frontend to manage connections to remote filesystems using GIO/GVFS"
+arch=('i686' 'x86_64')
+url="http://www.nic.funet.fi/pub/sci/graphics/packages/photomolo/photomolo.html"
+license=('GPL2')
+depends=('libjpeg-turbo')
+source=(http://www.nic.funet.fi/pub/sci/graphics/packages/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('8e277b95023b2e32171edeae5367e7f5')
+
+build() {
+ cd ${srcdir}/$pkgname-$pkgver
+
+ make
+}
+
+package() {
+ cd ${srcdir}/$pkgname-$pkgver
+
+ make PREFIX="${pkgdir}"/usr install installman
+
+ install -d "$pkgdir"/usr/share/doc/$pkgname
+ cp -r examples "$pkgdir"/usr/share/doc/$pkgname
+ chmod -x "$pkgdir"/usr/share/doc/$pkgname/examples/*
+}