summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladimír Magyar2022-01-03 20:21:11 +0100
committerVladimír Magyar2022-01-03 20:21:11 +0100
commit578773cf036fe2660fd1f7eeda67f2681edbfcb0 (patch)
tree59b7daf8bb9d3d36788010d5acb4686ccc1ee948
parent1edffd270e3bc172db598eb7a517180d6ef71106 (diff)
downloadaur-578773cf036fe2660fd1f7eeda67f2681edbfcb0.tar.gz
change to the terminal photon
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5bfbf2e7402e..b5c32d2fcc8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = photon-rss-git
- pkgdesc = Fast RSS reader as light as a photon
+ pkgdesc = RSS reader as light as a photon with terminal + sixel frontend
pkgver = r132.066f732
pkgrel = 1
url = https://git.sr.ht/~ghost08/photon
@@ -14,7 +14,7 @@ pkgbase = photon-rss-git
makedepends = git
makedepends = go
depends = glibc
- optdepends = youtube-dl: A command-line program to download videos from YouTube.com and a few more sites
+ optdepends = yt-dlp: A youtube-dl fork with additional features and fixes
optdepends = mpv: a free, open source, and cross-platform media player
optdepends = imv: Image viewer for Wayland and X11
provides = photon-rss
diff --git a/PKGBUILD b/PKGBUILD
index 08953bfdef90..bf1a88e3da77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
-# Maintainer: Vladimir Magyar <vladimi at mgyar dot me>
+# Maintainer: Vladimir Magyar <vladimir at mgyar dot me>
pkgname=photon-rss-git
-pkgver=r132.066f732
+pkgver=r54.e85a2d4
pkgrel=1
-pkgdesc="Fast RSS reader as light as a photon"
+pkgdesc="RSS reader as light as a photon with terminal + sixel frontend"
arch=("i686" "pentium4" "x86_64" "arm" "armv6h" "armv7h" "aarch64")
url="https://git.sr.ht/~ghost08/photon"
license=("GPL3")
depends=('glibc')
makedepends=('git' 'go')
optdepends=(
- "youtube-dl: A command-line program to download videos from YouTube.com and a few more sites"
+ "yt-dlp: A youtube-dl fork with additional features and fixes"
"mpv: a free, open source, and cross-platform media player"
"imv: Image viewer for Wayland and X11"
)
@@ -32,7 +32,7 @@ build() {
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
cd "$pkgname"
- go build -tags nox11
+ go build
}
check() {
@@ -50,5 +50,5 @@ package() {
cd "$pkgname"
install -Dm 755 photon -t "$pkgdir/usr/bin/"
install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
- install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+ #install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
}