aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIan Hartwig2023-10-29 22:48:51 -0700
committerIan Hartwig2023-10-29 22:59:31 -0700
commit1e6fd38dd1770ecbcf334b2f3c1bcff63707b8b9 (patch)
tree8297cdc2a5e9da8d57758374cbad11e0fa0a0456
parent11f821cadfbc35ff9367fde255eaf3909ce9f162 (diff)
downloadaur-1e6fd38dd1770ecbcf334b2f3c1bcff63707b8b9.tar.gz
add linux-lts dep to get kernel 6.1
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
-rw-r--r--photonvision-bin.install1
3 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12cf509c0a00..f0945e2d3bc1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = photonvision-bin
pkgdesc = free, fast, and easy-to-use computer vision solution for the FIRST Robotics Competition
pkgver = v2023.4.2
- pkgrel = 1
+ pkgrel = 2
url = https://photonvision.org/
install = photonvision-bin.install
arch = x86_64
@@ -9,6 +9,7 @@ pkgbase = photonvision-bin
depends = jre11-openjdk-headless
depends = avahi
depends = networkmanager
+ depends = linux-lts
noextract = photonvision-bin-v2023.4.2.jar
source = photonvision-bin-v2023.4.2.jar::https://github.com/PhotonVision/photonvision/releases/download/v2023.4.2/photonvision-v2023.4.2-linuxx64.jar
sha256sums = f2c81bcb7299cf77be2a66c577ab5724d74c2e7da6d0f9962366e99a2c37b280
diff --git a/PKGBUILD b/PKGBUILD
index 6eeeb4403298..adb4f35bf3b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Isaac Ruben <isaac at rubenfamily dot com>
pkgname='photonvision-bin'
pkgver="v2023.4.2"
-pkgrel=1
+pkgrel=2
pkgdesc="free, fast, and easy-to-use computer vision solution for the FIRST Robotics Competition"
arch=("x86_64")
url="https://photonvision.org/"
@@ -9,7 +9,7 @@ license=('GPL3')
source=("$pkgname-$pkgver.jar::https://github.com/PhotonVision/photonvision/releases/download/$pkgver/photonvision-$pkgver-linuxx64.jar")
noextract=("$pkgname-$pkgver.jar")
sha256sums=('f2c81bcb7299cf77be2a66c577ab5724d74c2e7da6d0f9962366e99a2c37b280')
-depends=('jre11-openjdk-headless' 'avahi' 'networkmanager')
+depends=('jre11-openjdk-headless' 'avahi' 'networkmanager' 'linux-lts')
install="photonvision-bin.install"
prepare() {
diff --git a/photonvision-bin.install b/photonvision-bin.install
index 67716fcb1d59..c3bbfa0a6693 100644
--- a/photonvision-bin.install
+++ b/photonvision-bin.install
@@ -2,6 +2,7 @@
post_install() {
echo "Warning: Photonvision will change the machine hostname to 'photonvision' on first run."
echo "This can be changed on the Settings page on the web ui at http://localhost:5800"
+ echo "If the linux-lts kernel dep was installed, a reboot is required to run with kernel 6.1."
echo "To enable the photonvision service: systemctl enable --now photonvision"
}