aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIan Hartwig2023-10-29 21:55:54 -0700
committerIan Hartwig2023-10-29 22:27:56 -0700
commit2a9fb60b97ebb2efdebe954344376537c9acfe57 (patch)
treedd3626161e0aafbc71b3c57bae397a6a6913c104
parenta22f4144586df35ff3610e23c16ab165f21ba606 (diff)
downloadaur-2a9fb60b97ebb2efdebe954344376537c9acfe57.tar.gz
bump jar version to v2023.4.2
-rw-r--r--PKGBUILD7
-rw-r--r--photonvision-bin.install12
2 files changed, 16 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 05b562866529..6eeeb4403298 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Isaac Ruben <isaac at rubenfamily dot com>
pkgname='photonvision-bin'
-pkgver="v2023.4.0"
+pkgver="v2023.4.2"
pkgrel=1
pkgdesc="free, fast, and easy-to-use computer vision solution for the FIRST Robotics Competition"
arch=("x86_64")
@@ -8,8 +8,9 @@ url="https://photonvision.org/"
license=('GPL3')
source=("$pkgname-$pkgver.jar::https://github.com/PhotonVision/photonvision/releases/download/$pkgver/photonvision-$pkgver-linuxx64.jar")
noextract=("$pkgname-$pkgver.jar")
-sha256sums=('8c707352b8af8c4499959f5d33b08824ae7e944f4396d4785bf176bdf708445c')
+sha256sums=('f2c81bcb7299cf77be2a66c577ab5724d74c2e7da6d0f9962366e99a2c37b280')
depends=('jre11-openjdk-headless' 'avahi' 'networkmanager')
+install="photonvision-bin.install"
prepare() {
# pulled from https://raw.githubusercontent.com/PhotonVision/photonvision/master/scripts/install.sh
@@ -42,7 +43,7 @@ package() {
cd "$srcdir"
# copy the jar file
- install -Dm644 "$pkgname-$pkgver.jar" "$pkgdir/opt/$pkgname/photonvision.jar"
+ install -Dm644 "$pkgname-$pkgver.jar" "$pkgdir/opt/$pkgname/photonvision.jar"
# copy the systemd service file
install -Dm644 photonvision.service "$pkgdir/etc/systemd/system/photonvision.service"
diff --git a/photonvision-bin.install b/photonvision-bin.install
new file mode 100644
index 000000000000..67716fcb1d59
--- /dev/null
+++ b/photonvision-bin.install
@@ -0,0 +1,12 @@
+## arg 1: the new package version
+post_install() {
+ echo "Warning: Photonvision will change the machine hostname to 'photonvision' on first run."
+ echo "This can be changed on the Settings page on the web ui at http://localhost:5800"
+ echo "To enable the photonvision service: systemctl enable --now photonvision"
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ echo "Restart the service to change to $1: systemctl restart photonvision"
+}