summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkaptoxic2016-08-30 19:13:29 -0400
committerkaptoxic2016-08-30 19:13:29 -0400
commit601eccf32d8ba1ad94c656f4e3718403f0d6a09c (patch)
treefdca2bb403e311300239f589050a7b8fe679f11a
downloadaur-601eccf32d8ba1ad94c656f4e3718403f0d6a09c.tar.gz
Revive original package
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD28
-rw-r--r--photoprint.install19
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e75c8aa9ffc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Tue Aug 30 23:13:20 UTC 2016
+pkgbase = photoprint
+ pkgdesc = PhotoPrint is a utility designed to assist in the process of printing digital photographs under Linux and other UNIX-like operating systems.
+ pkgver = 0.4.2rc2
+ pkgrel = 7
+ url = http://www.blackfiveimaging.co.uk/index.php?article=02Software%2F01PhotoPrint
+ install = photoprint.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gutenprint
+ makedepends = cups
+ depends = gtk2
+ depends = gutenprint
+ depends = lcms
+ depends = netpbm
+ depends = libjpeg
+ depends = libtiff
+ depends = hicolor-icon-theme
+ depends = desktop-file-utils
+ source = http://www.blackfiveimaging.co.uk/photoprint/photoprint-0.4.2-pre2.tar.gz
+ md5sums = fbd33857d37081846df43cb52a9db3a8
+
+pkgname = photoprint
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ddc2b541051e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Contributor: Frank Ickstadt (frank dot ickstadt at gmail dot com)
+# adpoted from Caved since pkgver=0.4.0-pre1
+
+pkgname=photoprint
+arch=(i686 x86_64)
+pkgver=0.4.2rc2
+pkgrel=7
+license=('GPL')
+pkgdesc="PhotoPrint is a utility designed to assist in the process of printing digital photographs under Linux and other UNIX-like operating systems."
+url="http://www.blackfiveimaging.co.uk/index.php?article=02Software%2F01PhotoPrint"
+depends=('gtk2' 'gutenprint' 'lcms' 'netpbm' 'libjpeg' 'libtiff' 'hicolor-icon-theme' 'desktop-file-utils')
+makedepends=('gutenprint' 'cups')
+backup=()
+install=${pkgname}.install
+source=(http://www.blackfiveimaging.co.uk/photoprint/photoprint-0.4.2-pre2.tar.gz)
+md5sums=('fbd33857d37081846df43cb52a9db3a8')
+
+build() {
+ cd ${srcdir}/photoprint-0.4.2-pre2
+ for file in $(find -name '*.c' -or -name '*.cpp' -or -name '*.h'); do sed -i 's|#include <glib/[^>]*>|#include <glib.h>|' $file ; done
+ ./configure --prefix=/usr
+ make CFLAGS="$CFLAGS -lX11" || return 1
+}
+
+package() {
+ cd ${srcdir}/photoprint-0.4.2-pre2
+ make DESTDIR=${pkgdir} install
+}
diff --git a/photoprint.install b/photoprint.install
new file mode 100644
index 000000000000..e76d3a1c4849
--- /dev/null
+++ b/photoprint.install
@@ -0,0 +1,19 @@
+## arrg 1: the new package version
+post_install() {
+ post_upgrade
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+## arg 1: the old package version
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+# vim:set ts=2 sw=2 et: