summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Spies2019-05-22 11:31:24 -0600
committerLukas Spies2019-05-22 11:31:24 -0600
commit649536ac4b404aabb322131aabe9825088a9621d (patch)
tree77889a5348fa6db0e0d44edf325607975b517de3
parent9db6e5c535da8602b3725ea852da9fd45a71f487 (diff)
downloadaur-649536ac4b404aabb322131aabe9825088a9621d.tar.gz
fix build with exiv 0.27
-rwxr-xr-xPKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8b2a7734bc4e..e6671d167c74 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,12 +13,15 @@ depends=('exiv2' 'graphicsmagick' 'qt5-imageformats' 'qt5-multimedia' 'qt5-svg'
optdepends=('libqpsd-git: PSB/PSD support'
'xcftools: XCF support')
makedepends=('cmake' 'qt5-tools' 'extra-cmake-modules')
-source=(http://photoqt.org/pkgs/$pkgname-$pkgver.tar.gz)
-md5sums=('656fee6f9923499992f069496a0aaa5d')
+source=(http://photoqt.org/pkgs/$pkgname-$pkgver.tar.gz
+ https://gitlab.com/luspi/photoqt/commit/c6fd41478e818f3a651d40f96cab3d790e1c09a4.diff)
+md5sums=('656fee6f9923499992f069496a0aaa5d' 'SKIP')
prepare() {
cd $srcdir/$pkgname-$pkgver
+ patch -p1 < ../c6fd41478e818f3a651d40f96cab3d790e1c09a4.diff
+
# To build PhotoQt with less features, add -Dxxxx=OFF to
# the next line (where xxxx is the respective CMake option).
cmake . -DCMAKE_INSTALL_PREFIX=/usr -DFREEIMAGE=OFF -DDEVIL=OFF