summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorluspi2018-05-28 15:16:41 +0200
committerluspi2018-05-28 15:16:41 +0200
commit6e8c75aa8f302ed2c89a374ceae0e3a2b5b40631 (patch)
treefa41d94661416ddf8908699cdb12495cc790091a
parentc65064a0ce430cd89c9d50e07ec6348ef8c5a0bf (diff)
downloadaur-6e8c75aa8f302ed2c89a374ceae0e3a2b5b40631.tar.gz
fix: Qt 5.11 removed qt5_use_modules() cmake function causes cmake to fail -> added patch to replace by target_link_libraries() cmake function
-rw-r--r--.SRCINFO4
-rwxr-xr-xPKGBUILD11
-rw-r--r--qt5usemodules.patch15
3 files changed, 26 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 051ec5971643..e1026c1bb011 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Tue May 15 22:40:04 UTC 2018
+# Mon May 28 13:15:53 UTC 2018
pkgbase = photoqt
pkgdesc = Fast and highly configurable image viewer with a simple and nice interface.
pkgver = 1.7
@@ -25,7 +25,9 @@ pkgbase = photoqt
optdepends = libqpsd-git: PSB/PSD support
optdepends = xcftools: XCF support
source = http://photoqt.org/pkgs/photoqt-1.7.tar.gz
+ source = qt5usemodules.patch
md5sums = cef43bab96392542a15aaae10b7b6aeb
+ md5sums = db9263e2ec6e85f50f4185765a4f633f
pkgname = photoqt
diff --git a/PKGBUILD b/PKGBUILD
index 6ebefb969015..5fb722245f3b 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,11 +13,16 @@ depends=('exiv2' 'graphicsmagick' 'qt5-imageformats' 'qt5-multimedia' 'qt5-svg'
optdepends=('libqpsd-git: PSB/PSD support'
'xcftools: XCF support')
makedepends=('cmake' 'qt5-tools' 'extra-cmake-modules')
-source=(http://photoqt.org/pkgs/$pkgname-$pkgver.tar.gz)
-md5sums=('cef43bab96392542a15aaae10b7b6aeb')
+source=(http://photoqt.org/pkgs/$pkgname-$pkgver.tar.gz
+ qt5usemodules.patch)
+md5sums=('cef43bab96392542a15aaae10b7b6aeb'
+ 'db9263e2ec6e85f50f4185765a4f633f')
prepare() {
cd $srcdir/$pkgname-$pkgver
+
+ # In Qt 5.11, qt5_use_modules() does not exist anymore and needs to be replaced by target_link_libraries()
+ patch < $srcdir/qt5usemodules.patch
# To build PhotoQt with less features, add -Dxxxx=OFF to
# the next line (where xxxx is the respective CMake option).
@@ -26,7 +31,7 @@ prepare() {
build() {
cd $srcdir/$pkgname-$pkgver
- make
+ make -j3
}
package() {
diff --git a/qt5usemodules.patch b/qt5usemodules.patch
new file mode 100644
index 000000000000..84da1676afe0
--- /dev/null
+++ b/qt5usemodules.patch
@@ -0,0 +1,15 @@
+--- CMakeLists.txt 2018-05-15 16:00:49.468725114 +0200
++++ CMakeLists.txt 2018-05-28 15:08:47.859120660 +0200
+@@ -135,10 +135,10 @@
+ # on windows we add application icons
+ if(WIN32)
+ add_executable(${PROJECT_NAME} WIN32 ${photoqt_SOURCES} ${photoqt_QML} ${RESOURCES} windowsicons.rc)
+- qt5_use_modules(${PROJECT_NAME} Quick Sql Svg Core Xml WinExtras)
++ target_link_libraries(${PROJECT_NAME} Qt5::Quick Qt5::Sql Qt5::Svg Qt5::Core Qt5::Xml Qt5::WinExtras)
+ elseif(NOT WIN32)
+ add_executable(${PROJECT_NAME} ${photoqt_SOURCES} ${photoqt_QML} ${RESOURCES})
+- qt5_use_modules(${PROJECT_NAME} Quick Sql Svg Core Xml)
++ target_link_libraries(${PROJECT_NAME} Qt5::Quick Qt5::Sql Qt5::Svg Qt5::Core Qt5::Xml)
+ endif(WIN32)
+
+