summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorluspi2018-05-15 16:47:54 +0200
committerluspi2018-05-15 16:47:54 +0200
commit9e313ccd7f8748054b8275513306cf323c79f991 (patch)
tree4b4af1bef023ff9f1e3fc4ecf60ccde6f29b5bd2
parenta684107a31a2d7883e21d580b889a61323de82dd (diff)
downloadaur-9e313ccd7f8748054b8275513306cf323c79f991.tar.gz
update to v1.7
-rw-r--r--.SRCINFO13
-rwxr-xr-xPKGBUILD10
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2d9ee806b1f6..021f24b17c0b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Feb 22 23:32:57 UTC 2018
+# Tue May 15 14:34:48 UTC 2018
pkgbase = photoqt
pkgdesc = Fast and highly configurable image viewer with a simple and nice interface.
- pkgver = 1.6
+ pkgver = 1.7
pkgrel = 1
url = http://photoqt.org/
arch = x86_64
@@ -18,10 +18,15 @@ pkgbase = photoqt
depends = libraw
depends = qt5-graphicaleffects
depends = hicolor-icon-theme
+ depends = poppler-qt5
+ depends = freeimage
+ depends = devil-ilut
+ depends = libarchive
+ depends = kimageformats
optdepends = libqpsd-git: PSB/PSD support
optdepends = xcftools: XCF support
- source = http://photoqt.org/pkgs/photoqt-1.6.tar.gz
- md5sums = a93a3f7eba55dcf3ccce7f56a8288bcd
+ source = http://photoqt.org/pkgs/photoqt-1.7.tar.gz
+ md5sums = 650c3c10c203880f69bfb22a604c7140
pkgname = photoqt
diff --git a/PKGBUILD b/PKGBUILD
index 6b4ffc494ec6..44e296b07901 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,24 @@
# Contributor: archtux <antonio dot arias99999 at gmail dot com>
pkgname=photoqt
-pkgver=1.6
+pkgver=1.7
pkgrel=1
pkgdesc="Fast and highly configurable image viewer with a simple and nice interface."
arch=('x86_64')
url="http://photoqt.org/"
license=('GPL2')
-depends=('exiv2' 'graphicsmagick' 'qt5-imageformats' 'qt5-multimedia' 'qt5-svg' 'qt5-quickcontrols' 'libraw' 'qt5-graphicaleffects' 'hicolor-icon-theme')
+depends=('exiv2' 'graphicsmagick' 'qt5-imageformats' 'qt5-multimedia' 'qt5-svg' 'qt5-quickcontrols' 'libraw' 'qt5-graphicaleffects' 'hicolor-icon-theme' 'poppler-qt5' 'freeimage' 'devil-ilut' 'libarchive' 'kimageformats')
optdepends=('libqpsd-git: PSB/PSD support'
'xcftools: XCF support')
makedepends=('cmake' 'qt5-tools')
source=(http://photoqt.org/pkgs/$pkgname-$pkgver.tar.gz)
-md5sums=('a93a3f7eba55dcf3ccce7f56a8288bcd')
+md5sums=('650c3c10c203880f69bfb22a604c7140')
prepare() {
cd $srcdir/$pkgname-$pkgver
- # If you want to build PhotoQt with less features(without exiv2, graphicsmagick and/or libraw),
- # add either of -DEXIV2=OFF -DGM=OFF -DRAW=OFF to the next line.
+ # To build PhotoQt with less features, add -Dxxxx=OFF to
+ # the next line (where xxxx is the respective CMake option).
cmake . -DCMAKE_INSTALL_PREFIX=/usr
}