summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Spies2015-07-28 11:22:39 -0230
committerLukas Spies2015-07-28 11:22:39 -0230
commitc111e9572f5eb8f913055bbe8699fe7e3d7f25a9 (patch)
tree7526a5b1b1f0e9607d530bc6d040f6a45fd2e68a
downloadaur-c111e9572f5eb8f913055bbe8699fe7e3d7f25a9.tar.gz
Update to 1.3
-rw-r--r--.SRCINFO24
-rwxr-xr-xPKGBUILD33
-rwxr-xr-xphotoqt.install13
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4b7a94dcb92
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = photoqt
+ pkgdesc = Fast and highly configurable image viewer with a simple and nice interface.
+ pkgver = 1.3
+ pkgrel = 1
+ url = http://photoqt.org/
+ install = photoqt.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ makedepends = qt5-tools
+ depends = exiv2
+ depends = graphicsmagick
+ depends = qt5-imageformats
+ depends = qt5-multimedia
+ depends = qt5-svg
+ depends = qt5-declarative
+ optdepends = libqpsd-git: PSB/PSD support
+ optdepends = xcftools: XCF support
+ source = http://photoqt.org/pkgs/photoqt-1.3.tar.gz
+ md5sums = 9240f33d0c4e55316ce96b1c1ef25042
+
+pkgname = photoqt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..ac567a5bb3d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: archtux <antonio dot arias99999 at gmail dot com>
+
+pkgname=photoqt
+pkgver=1.3
+pkgrel=1
+pkgdesc="Fast and highly configurable image viewer with a simple and nice interface."
+arch=('i686' 'x86_64')
+url="http://photoqt.org/"
+license=('GPL2')
+depends=('exiv2' 'graphicsmagick' 'qt5-imageformats' 'qt5-multimedia' 'qt5-svg' 'qt5-declarative')
+optdepends=('libqpsd-git: PSB/PSD support'
+ 'xcftools: XCF support')
+makedepends=('cmake' 'qt5-tools')
+install=$pkgname.install
+source=(http://photoqt.org/pkgs/$pkgname-$pkgver.tar.gz)
+md5sums=('9240f33d0c4e55316ce96b1c1ef25042')
+
+prepare() {
+ cd $srcdir/$pkgname-$pkgver
+
+ # If you want to build PhotoQt with less features(without exiv2 and graphicsmagick), add (-DEXIV2=OFF -DGM=OFF) to next line.
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
+}
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+} \ No newline at end of file
diff --git a/photoqt.install b/photoqt.install
new file mode 100755
index 000000000000..a8c158f92eb0
--- /dev/null
+++ b/photoqt.install
@@ -0,0 +1,13 @@
+
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+} \ No newline at end of file