summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOfer Kashayov2015-06-24 21:28:13 +0300
committerOfer Kashayov2015-06-24 21:28:13 +0300
commitbeaf06fabed59ce55adaa9ae8b3aa4b8445ea8c2 (patch)
tree36dd1566962b25b11728df41d67e985ccab676d5
downloadaur-beaf06fabed59ce55adaa9ae8b3aa4b8445ea8c2.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..76dd40630b3e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = phototonic
+ pkgdesc = Image Viewer and Organizer
+ pkgver = 1.5.54
+ pkgrel = 1
+ url = http://oferkv.github.io/phototonic/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = qt5-base
+ depends = exiv2
+ depends = libxkbcommon-x11
+ optdepends = qt5-imageformats: TIFF and TGA support
+ optdepends = qt5-svg: SVG support
+ provides = phototonic
+ source = https://github.com/oferkv/phototonic/archive/06e2f123ac1f8f368dcb4db641c05d92f69f966b.tar.gz
+ md5sums = f3b8d405cf3be8460c1347ce3c225340
+
+pkgname = phototonic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..113041f1ea27
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+pkgname=phototonic
+pkgver=1.5.54
+pkgrel=1
+pkgdesc="Image Viewer and Organizer"
+arch=('i686' 'x86_64')
+url="http://oferkv.github.io/phototonic/"
+license=('GPL3')
+depends=('qt5-base' 'exiv2' 'libxkbcommon-x11')
+optdepends=('qt5-imageformats: TIFF and TGA support' 'qt5-svg: SVG support')
+provides=('phototonic')
+source=("https://github.com/oferkv/phototonic/archive/06e2f123ac1f8f368dcb4db641c05d92f69f966b.tar.gz")
+md5sums=('f3b8d405cf3be8460c1347ce3c225340')
+
+build() {
+ cd "$srcdir/$pkgname-06e2f123ac1f8f368dcb4db641c05d92f69f966b"
+ qmake-qt5 PREFIX="/usr" \
+ QMAKE_CFLAGS_RELEASE="$CPPFLAGS $CFLAGS" \
+ QMAKE_CXXFLAGS_RELEASE="$CPPFLAGS $CXXFLAGS" \
+ QMAKE_LFLAGS_RELEASE="$LDFLAGS"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-06e2f123ac1f8f368dcb4db641c05d92f69f966b"
+ make INSTALL_ROOT="$pkgdir/" install
+}