summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Schleifenbaum2014-12-30 10:50:45 +0100
committerJohannes Schleifenbaum2014-12-30 10:50:45 +0100
commit61cbd91ad09c674dcd67b3510426b4788ea2b4fb (patch)
tree9204f3bc9b35e67ad8b40fb1b7da6addcd4a374f
downloadaur-61cbd91ad09c674dcd67b3510426b4788ea2b4fb.tar.gz
all packages in aur subfolder
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD32
-rw-r--r--php-box.install8
4 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a345d71dc65f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = php-box
+ pkgdesc = An application for building and managing Phars
+ pkgver = 2.5.0
+ pkgrel = 1
+ url = https://github.com/box-project/box2
+ install = php-box.install
+ arch = any
+ license = MIT
+ depends = php>=5.3.3
+ source = https://github.com/kherge-archive/Box/releases/download/2.5.0/box-2.5.0.phar
+ source = https://raw.github.com/box-project/box2/2.5.0/LICENSE
+ sha1sums = 5664cb4603917a77ea71fb325845e33d886cccb1
+ sha1sums = 75fd1f242e0592ff86b001a9bde433e034703b27
+ sha256sums = 12bf1ea121e364e288473633ff6c995cc7501a2541d4892da6f1f8eba0a2d791
+ sha256sums = ba2dfc30b9659262549c839894838d9a1fe78ca533d0338cebc2f4f634b3bb12
+
+pkgname = php-box
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0a76c779bda2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*.pkg.*
+pkg/
+src/
+*.pkg.*.sig
+*.src.tar.gz
+*.phar
+LICENSE
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b417daad03bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Johannes Schleifenbaum <johannes [at] js-webcoding [dot] de>
+# Contributor: Attila Bukor <r1pp3rj4ck [at] w4it [dot] eu>
+# Please report issues at https://github.com/jojosch/pkgbuilds
+
+pkgname=php-box
+pkgver=2.5.0
+pkgrel=1
+pkgdesc="An application for building and managing Phars"
+url="https://github.com/box-project/box2"
+license="MIT"
+arch=("any")
+depends=("php>=5.3.3")
+install="${pkgname}.install"
+source=(
+ "https://github.com/kherge-archive/Box/releases/download/${pkgver}/box-${pkgver}.phar"
+ "https://raw.github.com/box-project/box2/${pkgver}/LICENSE"
+)
+sha1sums=(
+ "5664cb4603917a77ea71fb325845e33d886cccb1"
+ "75fd1f242e0592ff86b001a9bde433e034703b27"
+)
+sha256sums=(
+ "12bf1ea121e364e288473633ff6c995cc7501a2541d4892da6f1f8eba0a2d791"
+ "ba2dfc30b9659262549c839894838d9a1fe78ca533d0338cebc2f4f634b3bb12"
+)
+
+package() {
+ install -D -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m755 "${srcdir}/box-${pkgver}.phar" "${pkgdir}/usr/share/webapps/bin/${pkgname}.phar"
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/usr/share/webapps/bin/${pkgname}.phar" "${pkgdir}/usr/bin/${pkgname}"
+}
diff --git a/php-box.install b/php-box.install
new file mode 100644
index 000000000000..5ebc8429be69
--- /dev/null
+++ b/php-box.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo
+ echo "php-box is installed as executable 'php-box'."
+}
+
+post_upgrade() {
+ post_install
+} \ No newline at end of file