aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormonotonee2015-08-03 16:35:50 -0400
committermonotonee2015-08-03 16:35:50 -0400
commit12a804043a4bdf5fdb8437c512d46f3bfdbc7865 (patch)
tree66b10b5407c375e3cd94366fa774865c14252aab
downloadaur-12a804043a4bdf5fdb8437c512d46f3bfdbc7865.tar.gz
Initial commit.
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore6
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD46
-rw-r--r--README.md10
5 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c962091bc043
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = php-box-git
+ pkgdesc = An application for building and managing phars.
+ pkgver = latest
+ pkgrel = 1
+ url = http://box-project.org/
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = php-composer
+ depends = php>=5.3.3
+ provides = box
+ conflicts = php-box
+ source = box2::git+https://github.com/box-project/box2.git
+ md5sums = SKIP
+
+pkgname = php-box-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..536a74b5734b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*
+!PKGBUILD
+!.gitignore
+!.SRCINFO
+!README.md
+!LICENSE
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..c6563a735b7e
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) 2015 monotonee
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c39cfe5c2fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: monotonee <monotonee at tuta dot io>
+# Note that the decision to use "latest" as pkgver was made based on the
+# PKGBUILD of aurvote-git and negates the necessity of manual updates.
+pkgname='php-box-git'
+_vcsRepoDir='box2'
+pkgver=2.5.2.r0.g046900a
+pkgrel=1
+pkgdesc='An application for building and managing phars.'
+arch=('any')
+url='http://box-project.org/'
+license=('MIT')
+depends=('php>=5.3.3')
+makedepends=('git' 'php-composer')
+conflicts=('php-box')
+provides=('box')
+source=($_vcsRepoDir'::git+https://github.com/box-project/box2.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_vcsRepoDir
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd $_vcsRepoDir
+ composer install --no-interaction
+}
+
+build() {
+ cd $_vcsRepoDir
+ bin/box build --no-interaction
+}
+
+check() {
+ cd $_vcsRepoDir
+ _pharName='box-'$(git describe --tags)'.phar'
+ echo 'Verifying built PHAR: '$(bin/box verify $_pharName)
+ echo 'Checking built PHAR version: '$(./$_pharName --version)
+}
+
+package() {
+ cd $_vcsRepoDir
+ _pharName='box-'$(git describe --tags)'.phar'
+ install -D -m755 $_pharName $pkgdir/usr/bin/${provides[0]}
+ install -D -m644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..f6d7c81b4505
--- /dev/null
+++ b/README.md
@@ -0,0 +1,10 @@
+# AUR php-box-git
+A [PKGBUILD](https://wiki.archlinux.org/index.php/PKGBUILD) script for use in
+the [Arch User Repository](https://aur4.archlinux.org/) that will build a
+package containing the latest version of the PHP
+[Box](https://github.com/box-project/box2) phar.
+
+## References
+[Arch Build System](https://wiki.archlinux.org/index.php/Arch_Build_System)
+[Creating Packages](https://wiki.archlinux.org/index.php/Creating_packages)
+[Building and Installing Packages](https://wiki.archlinux.org/index.php/Arch_Build_System#How_to_use_ABS)