summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMárk Sági-Kazár2016-06-07 13:56:03 +0200
committerMárk Sági-Kazár2016-06-07 14:19:59 +0200
commit7348b61ecc75b29d09f609a85825b2162ec5a907 (patch)
tree88f2a9a801a15b2ac6d4d4e7ef3366a167c1833c
downloadaur-7348b61ecc75b29d09f609a85825b2162ec5a907.tar.gz
Initial commit
Update srcinfo
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD21
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d963cdb66781
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = php-build
+ pkgdesc = Install PHP versions
+ pkgver = 0.10.0
+ pkgrel = 1
+ url = https://github.com/php-build/php-build
+ arch = any
+ license = MIT
+ conflicts = php-build-git
+ source = https://github.com/php-build/php-build/archive/v0.10.0.tar.gz
+ md5sums = fe93bff7b564d0ba05a672b663568e09
+
+pkgname = php-build
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3ffbbace5f02
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.pkg.tar
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..223d296ab833
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Márk Sági-Kazár <mark.sagi-kazar@gmail.com>
+
+pkgname=php-build
+pkgver=0.10.0
+pkgrel=1
+pkgdesc="Install PHP versions"
+arch=("any")
+url="https://github.com/php-build/php-build"
+license=("MIT")
+conflicts=("${pkgname}-git")
+source=("${url}/archive/v${pkgver}.tar.gz")
+md5sums=("fe93bff7b564d0ba05a672b663568e09")
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ PREFIX="$pkgdir/usr" ./install.sh
+}