summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Schleifenbaum2015-11-01 13:13:02 +0100
committerJohannes Schleifenbaum2015-11-01 13:13:02 +0100
commit59cdb5804855bf77962df68786480f207aea621b (patch)
treea0980f8fb13c3fa9d9a2eb2c78bc55260306cad6
parent1d148f1bf6ee40e2ba12a2fc9912c7646fc66a12 (diff)
downloadaur-59cdb5804855bf77962df68786480f207aea621b.tar.gz
Use prebuilt phar
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD24
3 files changed, 17 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f96d4595cd0..215f77e5fedc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = php-deprecation-detector
pkgdesc = static code analyzer for your project's source code to find usages of deprecated methods, classes and interfaces
pkgver = 0.1.0.alpha2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/sensiolabs-de/deprecation-detector
arch = any
license = MIT
- makedepends = php-box
- makedepends = php-composer
- makedepends = git
depends = php>=5.3.9
- source = git+https://github.com/sensiolabs-de/deprecation-detector.git#tag=0.1.0-alpha2
+ source = deprecation-detector-0.1.0-alpha2.phar::https://github.com/sensiolabs-de/deprecation-detector/releases/download/0.1.0-alpha2/deprecation-detector.phar
+ source = https://raw.github.com/sensiolabs-de/deprecation-detector/0.1.0-alpha2/LICENSE
+ sha256sums = f6943b698f30eaeb37a7903801d84454a404a6fe4cb4493e936a14dc8c7960db
sha256sums = SKIP
pkgname = php-deprecation-detector
diff --git a/.gitignore b/.gitignore
index c901733a2b24..8addc66e5488 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,3 +4,5 @@ src/
*.pkg.*.sig
*.src.tar.gz
deprecation-detector
+*.phar
+LICENSE \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 59f4c3fb099d..39fe0a22b8f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,28 +5,26 @@ _basename="deprecation-detector"
_tag="0.1.0-alpha2"
pkgname="php-${_basename}"
pkgver=${_tag/\-/\.}
-pkgrel=1
+pkgrel=2
pkgdesc="static code analyzer for your project's source code to find usages of deprecated methods, classes and interfaces"
url="https://github.com/sensiolabs-de/deprecation-detector"
license="MIT"
arch=("any")
depends=("php>=5.3.9")
-makedepends=("php-box" "php-composer" "git")
-source=("git+https://github.com/sensiolabs-de/deprecation-detector.git#tag=${_tag}")
-sha256sums=("SKIP")
-
-build() {
- cd "${srcdir}/${_basename}"
-
- composer install --prefer-dist --no-dev
- php-box build
-}
+source=(
+ "deprecation-detector-${_tag}.phar::https://github.com/sensiolabs-de/deprecation-detector/releases/download/${_tag}/deprecation-detector.phar"
+ "https://raw.github.com/sensiolabs-de/deprecation-detector/${_tag}/LICENSE"
+)
+sha256sums=(
+ "f6943b698f30eaeb37a7903801d84454a404a6fe4cb4493e936a14dc8c7960db"
+ "SKIP"
+)
package() {
- cd "${srcdir}/${_basename}"
+ cd "${srcdir}/"
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -D -m755 "${_basename}.phar" "${pkgdir}/usr/share/webapps/bin/${_basename}.phar"
+ install -D -m755 "deprecation-detector-${_tag}.phar" "${pkgdir}/usr/share/webapps/bin/${_basename}.phar"
install -d "${pkgdir}/usr/bin"
ln -s "/usr/share/webapps/bin/${_basename}.phar" "${pkgdir}/usr/bin/${_basename}"
}