summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2015-12-24 16:57:50 -0500
committerJames An2015-12-24 16:57:50 -0500
commit9dfdfe18f40bcbe55aeb7c5a91c973a7bff1b640 (patch)
tree67b0493adaac393531790e85d9ee84bd6aac2a45
downloadaur-9dfdfe18f40bcbe55aeb7c5a91c973a7bff1b640.tar.gz
Initial commit with working PKGBUILD.
-rw-r--r--.SRCINFO18
-rwxr-xr-x.gitignore27
-rw-r--r--PKGBUILD47
3 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..821c8198a01a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Dec 24 21:56:42 UTC 2015
+pkgbase = php-gtk-git
+ pkgdesc = PHP language bindings for GTK+ 2 toolkit.
+ pkgver = 2.0.1.r0.gc959799
+ pkgrel = 1
+ url = https://github.com/php/php-gtk-src
+ arch = any
+ license = LGPL2
+ makedepends = git
+ depends = gtk2
+ provides = php-gtk=2.0.1.r0.gc959799
+ conflicts = php-gtk
+ source = php-gtk::git+https://github.com/php/php-gtk-src.git
+ md5sums = SKIP
+
+pkgname = php-gtk-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100755
index 000000000000..43316bc3c124
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,27 @@
+# From: https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+
+*.tar
+*.tar.*
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+# makepkg working folders
+pkg
+src
+
+#
+# Additional ignore patterns:
+#
+
+# Source files
+*.deb
+*.gem
+*.out
+*.rpm
+*.html
+
+# Ignore package source folders
+*/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b129c1e21d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: James An <james@jamesan.ca>
+
+pkgname=php-gtk-git
+_pkgname=${pkgname%-git}
+pkgver=2.0.1.r0.gc959799
+pkgrel=1
+pkgdesc="PHP language bindings for GTK+ 2 toolkit."
+arch=('any')
+url="https://github.com/php/$_pkgname-src"
+license=('LGPL2')
+depends=('gtk2')
+makedepends=('git')
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname")
+options=()
+install=
+source=("$_pkgname"::"git+https://github.com/php/$_pkgname-src.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ (
+ set -o pipefail
+ git describe --long --tag | sed -r 's/([^-]*-g)/r\1/;s/-/./g;s/^v//' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "$_pkgname"
+
+ ./buildconf
+ ./configure --prefix=/usr --without-libglade
+ make
+}
+
+check() {
+ cd "$_pkgname"
+
+ NO_INTERACTION=1 make -k test
+}
+
+package() {
+ cd "$_pkgname"
+
+ make INSTALL_ROOT="$pkgdir/" install
+}