summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Galeotti2015-06-08 15:38:53 -0300
committerBruno Galeotti2015-06-08 15:38:53 -0300
commitac24c19b3638a06db182d9104818fb75198d212f (patch)
tree736ecb2efe04bc155b7b2b5a38511e2bd520350a
downloadaur-ac24c19b3638a06db182d9104818fb75198d212f.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fdee9ab884b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = php-inotify
+ pkgdesc = The inotify extension allows to use inotify functions in a PHP script.
+ pkgver = 0.1.6
+ pkgrel = 1
+ url = http://pecl.php.net/package/inotify
+ arch = i686
+ arch = x86_64
+ license = PHP
+ depends = php
+ backup = etc/php/conf.d/inotify.ini
+ source = http://pecl.php.net/get/inotify-0.1.6.tgz
+ sha256sums = 979f80a25d4eb0de282617ffc0df46f07346a8383f310b9b943e48992e5b494e
+
+pkgname = php-inotify
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..679d2c8d7b25
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=php-inotify
+pkgver=0.1.6
+pkgrel=1
+pkgdesc="The inotify extension allows to use inotify functions in a PHP script."
+arch=('i686' 'x86_64')
+url="http://pecl.php.net/package/inotify"
+license=('PHP')
+depends=('php')
+backup=('etc/php/conf.d/inotify.ini')
+source=(http://pecl.php.net/get/inotify-$pkgver.tgz)
+sha256sums=('979f80a25d4eb0de282617ffc0df46f07346a8383f310b9b943e48992e5b494e')
+
+build() {
+ cd "$srcdir/inotify-$pkgver"
+
+ phpize
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/inotify-$pkgver"
+
+ make INSTALL_ROOT="$pkgdir" install
+ echo ';extension=inotify.so' > inotify.ini
+ install -Dm644 inotify.ini "$pkgdir/etc/php/conf.d/inotify.ini"
+}
+
+# vim:set ts=2 sw=2 et: