summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormuhviehstarr2023-03-18 22:09:39 +0100
committermuhviehstarr2023-03-18 22:09:39 +0100
commit9c8fc50364ff8830fab94251474e73631a8d27ab (patch)
treea28b8947193f329e06a946414bbb18ff3d0487e8
parent6b72f36483410b3534c47ee946d28947a598f992 (diff)
downloadaur-9c8fc50364ff8830fab94251474e73631a8d27ab.tar.gz
php-legacy initial
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD42
-rw-r--r--php80.patch32
3 files changed, 30 insertions, 66 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ae967f149cf..9c7249a78683 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,32 +1,32 @@
-pkgbase = php-pdlib
+pkgbase = php-legacy-pdlib
pkgdesc = PDlib - A PHP extension for Dlib
- pkgver = 1.0.2
- pkgrel = 4
+ pkgver = 1.1.0
+ pkgrel = 1
url = https://github.com/goodspb/pdlib
arch = x86_64
license = MIT License
makedepends = cmake
depends = dlib
- depends = php
+ depends = php-legacy
depends = libx11
depends = openblas
+ depends = openblas64
depends = cblas
+ depends = cblas64
depends = lapack
+ depends = lapack64
depends = libsm
depends = libice
depends = libxext
- depends = giflib4
+ depends = giflib
depends = libpng
depends = zlib
depends = libjpeg-turbo
depends = sqlite
depends = fftw
- source = https://github.com/goodspb/pdlib/archive/v1.0.2.tar.gz
+ source = https://github.com/goodspb/pdlib/archive/v1.1.0.tar.gz
source = pdlib.ini
- source = php80.patch
- sha256sums = e91a3c7396ee2027f957fa34fcc2567e614e4e1c1570ae7d5d16d4203541ba4a
+ sha256sums = 6c255c07dfb70d34019faecd99160d03846c83925452c9e93d5606edc8d55803
sha256sums = c325ddedc2e685f12119a0f4e8a1a45430a1ecb15368179f4c0c7153352b8a0e
- sha256sums = d4ee8f30d0d056e0f538f54117d54d458404e47d7e5217e448e6bdc75aba1d38
-
-pkgname = php-pdlib
+pkgname = php-legacy-pdlib
diff --git a/PKGBUILD b/PKGBUILD
index 4dea9aa3a25e..65c440a8188d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,26 @@
# Maintainer: Timo Sarawinsi <tino@it-kraut.net>
-pkgname=("php-pdlib")
+pkgname=("php-legacy-pdlib")
_pkgbase=("pdlib")
-pkgver=1.0.2
-pkgrel=4
+pkgver=1.1.0
+pkgrel=1
pkgdesc="PDlib - A PHP extension for Dlib"
arch=('x86_64')
url="https://github.com/goodspb/pdlib"
license=('MIT License')
depends=('dlib'
- 'php'
+ 'php-legacy'
'libx11'
'openblas'
+ 'openblas64'
'cblas'
+ 'cblas64'
'lapack'
+ 'lapack64'
'libsm'
'libice'
'libxext'
- 'giflib4'
+ 'giflib'
'libpng'
'zlib'
'libjpeg-turbo'
@@ -27,24 +30,17 @@ depends=('dlib'
makedepends=('cmake')
source=("https://github.com/goodspb/pdlib/archive/v$pkgver.tar.gz"
- "pdlib.ini"
- "php80.patch")
-sha256sums=('e91a3c7396ee2027f957fa34fcc2567e614e4e1c1570ae7d5d16d4203541ba4a'
- 'c325ddedc2e685f12119a0f4e8a1a45430a1ecb15368179f4c0c7153352b8a0e'
- 'd4ee8f30d0d056e0f538f54117d54d458404e47d7e5217e448e6bdc75aba1d38')
-
-prepare() {
- cd "${srcdir}/${_pkgbase}-${pkgver}"
- patch -p1 -i ../php80.patch
-}
+ "pdlib.ini")
+sha256sums=('6c255c07dfb70d34019faecd99160d03846c83925452c9e93d5606edc8d55803'
+ 'c325ddedc2e685f12119a0f4e8a1a45430a1ecb15368179f4c0c7153352b8a0e')
build() {
- unset LDFLAGS
- export CXXFLAGS="-O2 -I/usr/include/giflib4"
- export LDFLAGS="-L/usr/lib/giflib4"
+ #unset LDFLAGS
+ #export CXXFLAGS="-O2 -I/usr/include/giflib4"
+ #export LDFLAGS="-L/usr/lib/giflib4"
cd "${srcdir}/${_pkgbase}-${pkgver}"
- phpize
- ./configure --with-php-config=/usr/bin/php-config --with-libdir=/usr/lib/giflib4
+ phpize-legacy
+ ./configure --enable-debug --with-php-config=/usr/bin/php-config-legacy
make
}
@@ -53,10 +49,10 @@ check() {
make NO_INTERACTION=1 test
}
-package_php-pdlib() {
+package_php-legacy-pdlib() {
cd "${srcdir}/${_pkgbase}-${pkgver}"
- install -Dm644 "modules/pdlib.so" "${pkgdir}/usr/lib/php/modules/pdlib.so"
+ install -Dm644 "modules/pdlib.so" "${pkgdir}/usr/lib/php-legacy/modules/pdlib.so"
# install ini file
- install -Dm644 "../pdlib.ini" "${pkgdir}/etc/php/conf.d/pdlib.ini"
+ install -Dm644 "../pdlib.ini" "${pkgdir}/etc/php-legacy/conf.d/pdlib.ini"
}
diff --git a/php80.patch b/php80.patch
deleted file mode 100644
index dd2440d9d04a..000000000000
--- a/php80.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff --git a/tests/cnn_face_detection_ctor_error.phpt b/tests/cnn_face_detection_ctor_error.phpt
-index 3535448..385e307 100644
---- a/tests/cnn_face_detection_ctor_error.phpt
-+++ b/tests/cnn_face_detection_ctor_error.phpt
-@@ -11,5 +11,5 @@ try {
- }
- ?>
- --EXPECTF--
--string(68) "CnnFaceDetection::__construct() expects exactly 1 parameter, 0 given"
-+string(%d) "CnnFaceDetection::__construct() expects exactly 1 %s, 0 given"
-
-diff --git a/tests/face_landmark_detection_ctor_error.phpt b/tests/face_landmark_detection_ctor_error.phpt
-index 2a717db..1f783f2 100644
---- a/tests/face_landmark_detection_ctor_error.phpt
-+++ b/tests/face_landmark_detection_ctor_error.phpt
-@@ -16,5 +16,5 @@ try {
- }
- ?>
- --EXPECTF--
--string(73) "FaceLandmarkDetection::__construct() expects exactly 1 parameter, 0 given"
-+string(%d) "FaceLandmarkDetection::__construct() expects exactly 1 %s, 0 given"
- string(45) "Unable to open non-existent file for reading."
-diff --git a/tests/face_recognition_ctor_error.phpt b/tests/face_recognition_ctor_error.phpt
-index c06ed39..237f2b0 100644
---- a/tests/face_recognition_ctor_error.phpt
-+++ b/tests/face_recognition_ctor_error.phpt
-@@ -11,4 +11,4 @@ try {
- }
- ?>
- --EXPECTF--
--string(67) "FaceRecognition::__construct() expects exactly 1 parameter, 0 given"
-+string(%d) "FaceRecognition::__construct() expects exactly 1 %s, 0 given"