summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormuhviehstarr2021-01-17 02:27:23 +0100
committermuhviehstarr2021-01-17 02:27:23 +0100
commitab198fc6dcc9a9393ce979a5a431c169fef0b5d4 (patch)
tree9522ebfd62a8e03379d822a384560c09b400ccbc
downloadaur-ab198fc6dcc9a9393ce979a5a431c169fef0b5d4.tar.gz
initial
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD42
-rw-r--r--pdlib.ini2
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..349b9c22d245
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = php-pdlib
+ pkgdesc = PDlib - A PHP extension for Dlib
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/goodspb/pdlib
+ arch = x86_64
+ license = MIT License
+ makedepends = cmake
+ depends = dlib
+ depends = php
+ depends = libx11
+ depends = openblas
+ depends = liblas
+ source = https://github.com/goodspb/pdlib/archive/v1.0.2.tar.gz
+ source = pdlib.ini
+ sha256sums = e91a3c7396ee2027f957fa34fcc2567e614e4e1c1570ae7d5d16d4203541ba4a
+ sha256sums = c325ddedc2e685f12119a0f4e8a1a45430a1ecb15368179f4c0c7153352b8a0e
+
+pkgname = php-pdlib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..365c7b57fb0c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Timo Sarawinsi <tino@it-kraut.net>
+
+pkgname=("php-pdlib")
+_pkgbase=("pdlib")
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="PDlib - A PHP extension for Dlib"
+arch=('x86_64')
+url="https://github.com/goodspb/pdlib"
+license=('MIT License')
+depends=('dlib'
+ 'php'
+ 'libx11'
+ 'openblas'
+ 'liblas')
+
+makedepends=('cmake')
+source=("https://github.com/goodspb/pdlib/archive/v$pkgver.tar.gz"
+ "pdlib.ini")
+sha256sums=('e91a3c7396ee2027f957fa34fcc2567e614e4e1c1570ae7d5d16d4203541ba4a'
+ 'c325ddedc2e685f12119a0f4e8a1a45430a1ecb15368179f4c0c7153352b8a0e')
+
+build() {
+ unset LDFLAGS
+ cd "${srcdir}/${_pkgbase}-${pkgver}"
+ phpize
+ ./configure --with-php-config=/usr/bin/php-config
+ make
+}
+
+check() {
+ cd "${srcdir}/${_pkgbase}-${pkgver}"
+ make NO_INTERACTION=1 test
+}
+
+package_php-pdlib() {
+ cd "${srcdir}/${_pkgbase}-${pkgver}"
+ install -Dm644 "modules/pdlib.so" "${pkgdir}/usr/lib/php/modules/pdlib.so"
+ # install ini file
+ install -Dm644 "../pdlib.ini" "${pkgdir}/etc/php/conf.d/pdlib.ini"
+}
+
diff --git a/pdlib.ini b/pdlib.ini
new file mode 100644
index 000000000000..ef1eabad5d32
--- /dev/null
+++ b/pdlib.ini
@@ -0,0 +1,2 @@
+[pdlib]
+extension=pdlib.so