summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortjbp2015-07-29 14:42:20 +0100
committertjbp2015-07-29 14:42:20 +0100
commit0c25710d0fd2abe216c74c79f555e921249f51e3 (patch)
treefd22ae0702d7a1e81cf6a50d642eb88ec0cd43a6
downloadaur-0c25710d0fd2abe216c74c79f555e921249f51e3.tar.gz
Migrated from AUR3, added backup option
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD40
-rw-r--r--liblua.so.patch12
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3d9b6139e1df
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = php-lua
+ pkgdesc = PHP PECL extension for an embedded Lua interpreter
+ pkgver = 1.1.0
+ pkgrel = 3
+ url = http://pecl.php.net/package/lua
+ arch = i686
+ arch = x86_64
+ license = PHP
+ depends = php>=5.1.0
+ depends = lua
+ backup = etc/php/conf.d/lua.ini
+ source = http://pecl.php.net/get/lua-1.1.0.tgz
+ source = liblua.so.patch
+ sha256sums = f063fb8e8ba5cfe5e120d179b84db77ea3344ce08288b48864ccb883a9826554
+ sha256sums = e193551d17c20fb6e053cfd2637a782e0f958c4c7500b6c77f5a427e7b10f400
+
+pkgname = php-lua
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..735a0571af86
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: tjbp (archlinux@tjbp.net)
+
+pkgname='php-lua'
+pkgver='1.1.0'
+pkgrel='3'
+pkgdesc='PHP PECL extension for an embedded Lua interpreter'
+arch=('i686' 'x86_64')
+url='http://pecl.php.net/package/lua'
+license=('PHP')
+depends=('php>=5.1.0' 'lua')
+source=(
+ "http://pecl.php.net/get/lua-$pkgver.tgz"
+ 'liblua.so.patch'
+)
+sha256sums=(
+ 'f063fb8e8ba5cfe5e120d179b84db77ea3344ce08288b48864ccb883a9826554'
+ 'e193551d17c20fb6e053cfd2637a782e0f958c4c7500b6c77f5a427e7b10f400'
+)
+backup=('etc/php/conf.d/lua.ini')
+
+prepare() {
+ patch -p0 -i liblua.so.patch
+}
+
+build() {
+ cd "$srcdir/lua-$pkgver"
+ phpize
+ ./configure \
+ --prefix=/usr \
+ --with-lua=/usr
+ make
+ echo 'extension=lua.so' > lua.ini
+}
+
+package() {
+ pushd "$srcdir/lua-$pkgver"
+ make INSTALL_ROOT="$pkgdir" install
+ install -Dm644 lua.ini "$pkgdir/etc/php/conf.d/lua.ini"
+ popd
+}
diff --git a/liblua.so.patch b/liblua.so.patch
new file mode 100644
index 000000000000..8a59a3f6e49a
--- /dev/null
+++ b/liblua.so.patch
@@ -0,0 +1,12 @@
+diff -ru lua-1.1.0/config.m4 lua-1.1.0.new/config.m4
+--- lua-1.1.0/config.m4 2013-10-23 05:21:11.000000000 +0100
++++ lua-1.1.0.new/config.m4 2014-03-27 22:48:03.341134040 +0000
+@@ -21,7 +21,7 @@
+ AC_MSG_ERROR(Please reinstall the lua distribution - lua.h should be in <lua-dir>/include/)
+ fi
+
+- LUA_LIB_NAME=liblua.a
++ LUA_LIB_NAME=liblua.so
+
+ if test -r $PHP_LUA/$PHP_LIBDIR/${LUA_LIB_NAME}; then
+ LUA_LIB_DIR=$PHP_LUA/$PHP_LIBDIR