summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKokaKiwi2023-04-28 19:46:03 +0200
committerKokaKiwi2023-04-28 19:46:03 +0200
commitdbb7ec75e9e3a3f0e03e84ff93a3b21593e79f7d (patch)
treecc42ebcbb9315a4950f97d1c3bc4c04c29e3de60
downloadaur-dbb7ec75e9e3a3f0e03e84ff93a3b21593e79f7d.tar.gz
Initial upload: php-luasandbox 4.1.0-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b63fa4b2617a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = php-luasandbox
+ pkgdesc = PHP extension that provides a sandboxed environment to run Lua scripts in
+ pkgver = 4.1.0
+ pkgrel = 1
+ url = https://www.mediawiki.org/wiki/LuaSandbox
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = php
+ depends = lua51
+ source = php-luasandbox-4.1.0.tar.gz::https://github.com/wikimedia/mediawiki-php-luasandbox/archive/refs/tags/4.1.0.tar.gz
+ sha256sums = 52df81fb659691f32cd6a51ae521ac5a982c30383d68e9d34338a0c3dec28e72
+ b2sums = 169e023a6f4c4b9d92114d80b05c81e07e487950c27c3bc4f25dd5c0c3b5915469fb997c7ae65b132a66c5e04c1c5d008e252589ed152acb046ecbb15e1b76b1
+
+pkgname = php-luasandbox
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b252d2c7abfe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: KokaKiwi <kokakiwi+aur [at] kokakiwi.net>
+
+pkgname=php-luasandbox
+pkgver=4.1.0
+pkgrel=1
+pkgdesc='PHP extension that provides a sandboxed environment to run Lua scripts in'
+arch=('i686' 'x86_64')
+url='https://www.mediawiki.org/wiki/LuaSandbox'
+license=('MIT')
+depends=('php' 'lua51')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/wikimedia/mediawiki-php-luasandbox/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('52df81fb659691f32cd6a51ae521ac5a982c30383d68e9d34338a0c3dec28e72')
+b2sums=('169e023a6f4c4b9d92114d80b05c81e07e487950c27c3bc4f25dd5c0c3b5915469fb997c7ae65b132a66c5e04c1c5d008e252589ed152acb046ecbb15e1b76b1')
+
+build() {
+ cd "mediawiki-php-luasandbox-$pkgver"
+
+ phpize
+ ./configure \
+ --prefix=/usr
+
+ make
+}
+
+package() {
+ cd "mediawiki-php-luasandbox-$pkgver"
+
+ make install INSTALL_ROOT="$pkgdir"
+ install -Dm0644 -t "$pkgdir/etc/php/conf.d" luasandbox.ini
+
+ install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname" COPYING
+}