summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Schleifenbaum2015-04-13 10:04:21 +0200
committerJohannes Schleifenbaum2015-04-13 10:04:21 +0200
commitc4bb66c79864f897aa2cd523796d0d26ce5eaec1 (patch)
treebd717a24170b06864d3b549f77af69792e278c6b
downloadaur-c4bb66c79864f897aa2cd523796d0d26ce5eaec1.tar.gz
imported repo
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD27
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e515032aeb3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by makepkg 4.2.1
+# Mon Apr 13 07:59:19 UTC 2015
+pkgbase = php-mailparse
+ pkgdesc = Extension for parsing and working with email messages (RFC822 and RFC2045)
+ pkgver = 2.1.6
+ pkgrel = 3
+ url = http://pecl.php.net/package/mailparse
+ arch = i686
+ arch = x86_64
+ license = PHP
+ depends = php
+ source = http://pecl.php.net/get/mailparse-2.1.6.tgz
+ sha256sums = 73705197d2b2ee782efa5477eb2a21432f592c2cb05a72c3a037bbe39e02b5cc
+
+pkgname = php-mailparse
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e523e10e02cb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*.pkg.*
+pkg/
+src/
+*.pkg.*.sig
+*.src.tar.gz
+*.tgz
+!.SRCINFO \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8dd79a177624
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Johannes Schleifenbaum <johannes [at] js-webcoding [dot] de>
+# Please report issues at https://github.com/jojosch/pkgbuilds
+
+pkgname=php-mailparse
+pkgver=2.1.6
+pkgrel=3
+pkgdesc="Extension for parsing and working with email messages (RFC822 and RFC2045)"
+arch=('i686' 'x86_64')
+url="http://pecl.php.net/package/mailparse"
+license=('PHP')
+depends=('php')
+source=("http://pecl.php.net/get/mailparse-${pkgver}.tgz")
+sha256sums=('73705197d2b2ee782efa5477eb2a21432f592c2cb05a72c3a037bbe39e02b5cc')
+
+build() {
+ cd "${srcdir}/mailparse-${pkgver}/"
+
+ phpize
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/mailparse-${pkgver}/"
+
+ make INSTALL_ROOT="${pkgdir}/" install
+}