summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBoris Momčilović2019-08-05 13:26:05 +0200
committerBoris Momčilović2019-08-05 13:26:05 +0200
commit06a79c5553dc0e85d224bd7d74040a5bcfe954ef (patch)
tree209d3c1beced861539c7c2b6daab8ec60aaa83a2
downloadaur-06a79c5553dc0e85d224bd7d74040a5bcfe954ef.tar.gz
Init
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD41
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..17da1866dab4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = php-nocheq-git
+ pkgdesc = Sick of pesky type checking making your code too slow (and correct) ?
+ pkgver = r27.5211a7b
+ pkgrel = 1
+ url = https://github.com/krakjoe/nocheq
+ arch = i686
+ arch = x86_64
+ license = PHP
+ makedepends = git
+ depends = php
+ backup = etc/php/conf.d/nocheq.ini
+ source = git://github.com/krakjoe/nocheq.git
+ md5sums = SKIP
+
+pkgname = php-nocheq-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a65a951aad34
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+!.gitignore
+php-nocheq-git*
+nocheq/
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6d5ca0653cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Boris Momčilović <boris.momcilovic@gmail.com>
+
+_pkgname=nocheq
+pkgname=php-$_pkgname-git
+pkgver=r27.5211a7b
+pkgrel=1
+pkgdesc="Sick of pesky type checking making your code too slow (and correct) ?"
+arch=('i686' 'x86_64')
+url="https://github.com/krakjoe/nocheq"
+license=('PHP')
+depends=('php')
+makedepends=('git')
+source=(git://github.com/krakjoe/nocheq.git)
+md5sums=('SKIP')
+_ininame="nocheq.ini"
+_inifile="etc/php/conf.d/$_ininame"
+backup=("$_inifile")
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+
+ phpize
+ ./configure --prefix=/usr
+ make
+ #TEST_PHP_EXECUTABLE=`which php` php run-tests.php
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make PREFIX=/usr INSTALL_ROOT="$pkgdir" install
+ cat >> "$_ininame" <<EOF
+;extension=nocheq.so
+EOF
+
+ install -vDm644 "$_ininame" "$pkgdir/$_inifile"
+}