aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpencer Rinehart2014-07-16 07:52:25 -0400
committerSpencer Rinehart2015-06-10 12:52:51 -0500
commitda68280c3287fe49283eb7ad9e7ab64c20bffd25 (patch)
treefca6ea0bd184f11761202d4a0239f12798a95f31
downloadaur-da68280c3287fe49283eb7ad9e7ab64c20bffd25.tar.gz
Initial commit with docker builld.
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--Dockerfile12
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD30
-rw-r--r--README.md27
-rw-r--r--fig.yml4
7 files changed, 114 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d2b927acb2ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = php-oci8
+ pkgdesc = PHP extension for OCI8
+ pkgver = 2.0.8
+ pkgrel = 5
+ url = http://pecl.php.net/package/oci8
+ arch = x86_64
+ license = PHP
+ depends = php>=5.1.3
+ depends = oracle-instantclient-sdk
+ backup = etc/php/conf.d/oci8.ini
+ source = http://pecl.php.net/get/oci8-2.0.8.tgz
+ md5sums = 9de75c4649bb047c6192f13092f9751d
+
+pkgname = php-oci8
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..660688b29478
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/oci8-*.tgz
+/php-oci8-*.pkg.tar.xz
+/php-oci8-*.src.tar.gz
+/pkg/
+/src/
diff --git a/Dockerfile b/Dockerfile
new file mode 100644
index 000000000000..44aa7a2a3529
--- /dev/null
+++ b/Dockerfile
@@ -0,0 +1,12 @@
+FROM nubs/arch-build
+
+MAINTAINER Spencer Rinehart <anubis@overthemonkey.com>
+
+USER root
+
+RUN bash -c 'echo -e "[oracle]\nSigLevel = Optional TrustAll\nServer = http://linux.shikadi.net/arch/\$repo/\$arch/" >>/etc/pacman.conf'
+
+RUN pacman --sync --refresh --noconfirm --noprogressbar --quiet
+RUN pacman --sync --noconfirm --noprogressbar --quiet php oracle-instantclient-sdk
+
+USER build
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..8fb49f589d7c
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) 2014 Spencer Rinehart
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6edd56730670
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Spencer Rinehart <anubis@overthemonkey.com>
+
+pkgname=php-oci8
+_extname=oci8
+pkgver=2.0.8
+pkgrel=5
+pkgdesc="PHP extension for OCI8"
+arch=('x86_64')
+url="http://pecl.php.net/package/${_extname}"
+license=('PHP')
+depends=('php>=5.1.3' 'oracle-instantclient-sdk')
+backup=("etc/php/conf.d/${_extname}.ini")
+source=("http://pecl.php.net/get/${_extname}-${pkgver}.tgz")
+md5sums=('9de75c4649bb047c6192f13092f9751d')
+
+build() {
+ cd "${_extname}-${pkgver}"
+
+ phpize
+ ./configure --prefix=/usr --with-oci8=instantclient,/usr/lib
+ make
+}
+
+package() {
+ cd "${_extname}-${pkgver}"
+
+ make INSTALL_ROOT="${pkgdir}" install
+ echo "extension=${_extname}.so" > "${_extname}.ini"
+ install -D -m644 "${_extname}.ini" "${pkgdir}/etc/php/conf.d/${_extname}.ini"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..14407fdb6692
--- /dev/null
+++ b/README.md
@@ -0,0 +1,27 @@
+# php-oci8-aur
+An [AUR] package build for PHP's [OCI8] extension.
+
+## Building
+You can of course build this package using [makepkg], but the recommended way
+of building this package is using [Docker]. This can be done like so:
+
+```bash
+docker build --tag php-oci8-aur .
+docker run --rm --volume "$(pwd):/package" php-oci8-aur
+```
+
+Alternatively, using [Fig]:
+
+```bash
+fig run build
+```
+
+This will start create a docker image tagged as php-oci8-aur and build the
+package inside the container. As a result you should get the built package in
+your current directory.
+
+[AUR]: https://aur.archlinux.org/
+[oci8]: http://pecl.php.net/package/oci8
+[makepkg]: https://wiki.archlinux.org/index.php/Makepkg
+[Docker]: https://www.docker.com/
+[Fig]: http://www.fig.sh/
diff --git a/fig.yml b/fig.yml
new file mode 100644
index 000000000000..b11c60fa7962
--- /dev/null
+++ b/fig.yml
@@ -0,0 +1,4 @@
+build:
+ build: .
+ volumes:
+ - ".:/package"