summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Gerbet2021-10-06 08:34:32 +0200
committerThomas Gerbet2021-10-06 08:34:32 +0200
commit5b77818fdd9166b95c849ce1889a2e88c5e1a5e4 (patch)
treefd99c75fff7458bda7475474d971302faf8264a1
parent7d3ac31c94d952ee775ad7db4f49833a5798c3cf (diff)
downloadaur-5b77818fdd9166b95c849ce1889a2e88c5e1a5e4.tar.gz
Bump to 1.0.9
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a616cfa4d26..71ad90907d01 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,17 @@
pkgbase = php-pcov
pkgdesc = Code coverage driver
- pkgver = 1.0.6
- pkgrel = 2
+ pkgver = 1.0.9
+ pkgrel = 1
url = https://pecl.php.net/package/pcov
arch = x86_64
license = PHP
- depends = php>=7.1.0
+ depends = php>=8.0.0
backup = etc/php/conf.d/pcov.ini
- source = https://pecl.php.net/get/pcov-1.0.6.tgz
+ source = https://pecl.php.net/get/pcov-1.0.9.tgz
source = pcov.ini
- source = https://raw.githubusercontent.com/php/php-src/php-7.1.0/run-tests.php
- source = php8-test.patch::https://github.com/krakjoe/pcov/commit/7c0cfac1f536396f7169f4ec46419941a0e61314.patch
- sha256sums = 61039955ad242d7a295251bca2f05c8e4c603abbc9e0f82bfa45009699e64edf
+ source = https://raw.githubusercontent.com/php/php-src/php-8.0.0/run-tests.php
+ sha256sums = 201cf12c5531c2f99434d29a3d9fa7ddc12f0bf48c17901f1e9fdfdf69795160
sha256sums = f3ef921748a263be6806b5dd83eeca7c686e0a4b6334fad19ab4e40d384f5d0a
sha256sums = 3c8b1c7eee9da4c9dea9de040a2b2ddcd8e48546af6322628c617c17e5edc0ff
- sha256sums = cd39b0f6ee2510aae4c3fb8fe6503747943c96caf25c262b2bed63ff7db8c0db
pkgname = php-pcov
-
diff --git a/PKGBUILD b/PKGBUILD
index 7f8b1e42990a..ebceddaacb14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,23 @@
# Maintainer: Thomas Gerbet <thomas at gerbet dot me>
pkgname=php-pcov
-pkgver=1.0.6
-pkgrel=2
+pkgver=1.0.9
+pkgrel=1
pkgdesc='Code coverage driver'
arch=('x86_64')
url='https://pecl.php.net/package/pcov'
license=('PHP')
-depends=('php>=7.1.0')
+depends=('php>=8.0.0')
backup=('etc/php/conf.d/pcov.ini')
source=("https://pecl.php.net/get/pcov-${pkgver}.tgz"
'pcov.ini'
- 'https://raw.githubusercontent.com/php/php-src/php-7.1.0/run-tests.php'
- 'php8-test.patch::https://github.com/krakjoe/pcov/commit/7c0cfac1f536396f7169f4ec46419941a0e61314.patch')
-sha256sums=('61039955ad242d7a295251bca2f05c8e4c603abbc9e0f82bfa45009699e64edf'
+ 'https://raw.githubusercontent.com/php/php-src/php-8.0.0/run-tests.php')
+sha256sums=('201cf12c5531c2f99434d29a3d9fa7ddc12f0bf48c17901f1e9fdfdf69795160'
'f3ef921748a263be6806b5dd83eeca7c686e0a4b6334fad19ab4e40d384f5d0a'
- '3c8b1c7eee9da4c9dea9de040a2b2ddcd8e48546af6322628c617c17e5edc0ff'
- 'cd39b0f6ee2510aae4c3fb8fe6503747943c96caf25c262b2bed63ff7db8c0db')
+ '3c8b1c7eee9da4c9dea9de040a2b2ddcd8e48546af6322628c617c17e5edc0ff')
build() {
cd "${srcdir}/pcov-${pkgver}/"
- patch --forward --strip=1 --input="${srcdir}/php8-test.patch"
phpize
./configure --prefix=/usr