summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Gerbet2019-01-30 22:08:57 +0100
committerThomas Gerbet2019-01-30 22:15:59 +0100
commit8617bdad3d0bdd9bf7b8e32b9f748b855c2e5826 (patch)
treef6346309136e373ca810a64f1ad445d5dae9a2f0
downloadaur-8617bdad3d0bdd9bf7b8e32b9f748b855c2e5826.tar.gz
Initial commit: pcov 1.0.0
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD43
-rw-r--r--pcov.ini3
4 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..64653cbf7b6a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = php-pcov
+ pkgdesc = Code coverage driver
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://pecl.php.net/package/pcov
+ arch = x86_64
+ license = PHP
+ depends = php>=7.1.0
+ backup = etc/php/conf.d/pcov.ini
+ source = https://pecl.php.net/get/pcov-1.0.0.tgz
+ source = pcov.ini
+ source = https://raw.githubusercontent.com/php/php-src/php-7.1.0/run-tests.php
+ sha256sums = 9e569d5cec18e3c188492ac7bd060b6f49d496a6a5d7a87e0e4ed7a521116703
+ sha256sums = f3ef921748a263be6806b5dd83eeca7c686e0a4b6334fad19ab4e40d384f5d0a
+ sha256sums = 3c8b1c7eee9da4c9dea9de040a2b2ddcd8e48546af6322628c617c17e5edc0ff
+
+pkgname = php-pcov
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fa4d467edb1b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tgz
+*.xz
+run-tests.php
+/pkg
+/src \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e8503d10ca1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Thomas Gerbet <thomas at gerbet dot me>
+
+pkgname=php-pcov
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Code coverage driver'
+arch=('x86_64')
+url='https://pecl.php.net/package/pcov'
+license=('PHP')
+depends=('php>=7.1.0')
+backup=('etc/php/conf.d/pcov.ini')
+source=("https://pecl.php.net/get/pcov-${pkgver}.tgz"
+ 'pcov.ini'
+ 'https://raw.githubusercontent.com/php/php-src/php-7.1.0/run-tests.php')
+sha256sums=('9e569d5cec18e3c188492ac7bd060b6f49d496a6a5d7a87e0e4ed7a521116703'
+ 'f3ef921748a263be6806b5dd83eeca7c686e0a4b6334fad19ab4e40d384f5d0a'
+ '3c8b1c7eee9da4c9dea9de040a2b2ddcd8e48546af6322628c617c17e5edc0ff')
+
+build() {
+ cd "${srcdir}/pcov-${pkgver}/"
+
+ phpize
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "${srcdir}/pcov-${pkgver}/"
+
+ export REPORT_EXIT_STATUS=1
+ export NO_INTERACTION=1
+ export SKIP_ONLINE_TESTS=1
+ export SKIP_SLOW_TESTS=1
+ export TEST_PHP_ARGS='-n -d extension=modules/pcov.so'
+ php run-tests.php -P
+}
+
+package() {
+ cd "${srcdir}/pcov-${pkgver}/"
+
+ make INSTALL_ROOT="${pkgdir}/" install
+ install -D -m 644 "$srcdir"/pcov.ini "$pkgdir"/etc/php/conf.d/pcov.ini
+} \ No newline at end of file
diff --git a/pcov.ini b/pcov.ini
new file mode 100644
index 000000000000..eaad567fe93d
--- /dev/null
+++ b/pcov.ini
@@ -0,0 +1,3 @@
+extension=pcov.so
+
+pcov.enabled = 0