summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormuhviehstarr2021-04-03 23:35:47 +0200
committermuhviehstarr2021-04-03 23:35:47 +0200
commit6b72f36483410b3534c47ee946d28947a598f992 (patch)
tree303f89af1d1e6ade78f8668d6a68432ecc5be401
parente005d7bbff0f377c9a74ec094c21a38021085cfd (diff)
downloadaur-6b72f36483410b3534c47ee946d28947a598f992.tar.gz
giflib4 php80
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
-rw-r--r--php80.patch32
3 files changed, 50 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0d2e4380029..1ae967f149cf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = php-pdlib
pkgdesc = PDlib - A PHP extension for Dlib
pkgver = 1.0.2
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/goodspb/pdlib
arch = x86_64
license = MIT License
@@ -15,7 +15,7 @@ pkgbase = php-pdlib
depends = libsm
depends = libice
depends = libxext
- depends = giflib
+ depends = giflib4
depends = libpng
depends = zlib
depends = libjpeg-turbo
@@ -23,8 +23,10 @@ pkgbase = php-pdlib
depends = fftw
source = https://github.com/goodspb/pdlib/archive/v1.0.2.tar.gz
source = pdlib.ini
+ source = php80.patch
sha256sums = e91a3c7396ee2027f957fa34fcc2567e614e4e1c1570ae7d5d16d4203541ba4a
sha256sums = c325ddedc2e685f12119a0f4e8a1a45430a1ecb15368179f4c0c7153352b8a0e
+ sha256sums = d4ee8f30d0d056e0f538f54117d54d458404e47d7e5217e448e6bdc75aba1d38
pkgname = php-pdlib
diff --git a/PKGBUILD b/PKGBUILD
index 470a63d5570f..4dea9aa3a25e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=("php-pdlib")
_pkgbase=("pdlib")
pkgver=1.0.2
-pkgrel=3
+pkgrel=4
pkgdesc="PDlib - A PHP extension for Dlib"
arch=('x86_64')
url="https://github.com/goodspb/pdlib"
@@ -17,7 +17,7 @@ depends=('dlib'
'libsm'
'libice'
'libxext'
- 'giflib'
+ 'giflib4'
'libpng'
'zlib'
'libjpeg-turbo'
@@ -27,15 +27,24 @@ depends=('dlib'
makedepends=('cmake')
source=("https://github.com/goodspb/pdlib/archive/v$pkgver.tar.gz"
- "pdlib.ini")
+ "pdlib.ini"
+ "php80.patch")
sha256sums=('e91a3c7396ee2027f957fa34fcc2567e614e4e1c1570ae7d5d16d4203541ba4a'
- 'c325ddedc2e685f12119a0f4e8a1a45430a1ecb15368179f4c0c7153352b8a0e')
+ 'c325ddedc2e685f12119a0f4e8a1a45430a1ecb15368179f4c0c7153352b8a0e'
+ 'd4ee8f30d0d056e0f538f54117d54d458404e47d7e5217e448e6bdc75aba1d38')
+
+prepare() {
+ cd "${srcdir}/${_pkgbase}-${pkgver}"
+ patch -p1 -i ../php80.patch
+}
build() {
unset LDFLAGS
+ export CXXFLAGS="-O2 -I/usr/include/giflib4"
+ export LDFLAGS="-L/usr/lib/giflib4"
cd "${srcdir}/${_pkgbase}-${pkgver}"
phpize
- ./configure --with-php-config=/usr/bin/php-config
+ ./configure --with-php-config=/usr/bin/php-config --with-libdir=/usr/lib/giflib4
make
}
diff --git a/php80.patch b/php80.patch
new file mode 100644
index 000000000000..dd2440d9d04a
--- /dev/null
+++ b/php80.patch
@@ -0,0 +1,32 @@
+diff --git a/tests/cnn_face_detection_ctor_error.phpt b/tests/cnn_face_detection_ctor_error.phpt
+index 3535448..385e307 100644
+--- a/tests/cnn_face_detection_ctor_error.phpt
++++ b/tests/cnn_face_detection_ctor_error.phpt
+@@ -11,5 +11,5 @@ try {
+ }
+ ?>
+ --EXPECTF--
+-string(68) "CnnFaceDetection::__construct() expects exactly 1 parameter, 0 given"
++string(%d) "CnnFaceDetection::__construct() expects exactly 1 %s, 0 given"
+
+diff --git a/tests/face_landmark_detection_ctor_error.phpt b/tests/face_landmark_detection_ctor_error.phpt
+index 2a717db..1f783f2 100644
+--- a/tests/face_landmark_detection_ctor_error.phpt
++++ b/tests/face_landmark_detection_ctor_error.phpt
+@@ -16,5 +16,5 @@ try {
+ }
+ ?>
+ --EXPECTF--
+-string(73) "FaceLandmarkDetection::__construct() expects exactly 1 parameter, 0 given"
++string(%d) "FaceLandmarkDetection::__construct() expects exactly 1 %s, 0 given"
+ string(45) "Unable to open non-existent file for reading."
+diff --git a/tests/face_recognition_ctor_error.phpt b/tests/face_recognition_ctor_error.phpt
+index c06ed39..237f2b0 100644
+--- a/tests/face_recognition_ctor_error.phpt
++++ b/tests/face_recognition_ctor_error.phpt
+@@ -11,4 +11,4 @@ try {
+ }
+ ?>
+ --EXPECTF--
+-string(67) "FaceRecognition::__construct() expects exactly 1 parameter, 0 given"
++string(%d) "FaceRecognition::__construct() expects exactly 1 %s, 0 given"