summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWalter Dworak2017-10-07 14:24:08 -0500
committerWalter Dworak2017-10-07 14:24:08 -0500
commitbb818cb4a4e8f55de75affec173d98f1d0b4900d (patch)
tree43b7cc351ffa7d313086200b032155af2a79999c
downloadaur-bb818cb4a4e8f55de75affec173d98f1d0b4900d.tar.gz
Initial packa
-rw-r--r--.SRCINFO44
-rw-r--r--PKGBUILD127
2 files changed, 171 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9ee18989756d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,44 @@
+# Generated by mksrcinfo v8
+# Sat Oct 7 19:19:28 UTC 2017
+pkgbase = php-pear-src
+ pkgdesc = PHP Extension and Application Repository
+ pkgver = 1.10.5
+ pkgrel = 1
+ url = http://pear.php.net
+ arch = i686
+ arch = x86_64
+ license = PHP
+ makedepends = apache
+ makedepends = c-client
+ makedepends = postgresql-libs
+ makedepends = libldap
+ makedepends = smtp-forwarder
+ makedepends = sqlite
+ makedepends = unixodbc
+ makedepends = net-snmp
+ makedepends = libzip
+ makedepends = enchant
+ makedepends = file
+ makedepends = freetds
+ makedepends = libmcrypt
+ makedepends = tidyhtml
+ makedepends = aspell
+ makedepends = libltdl
+ makedepends = gd
+ makedepends = icu
+ makedepends = curl
+ makedepends = libxslt
+ makedepends = openssl
+ makedepends = db
+ makedepends = gmp
+ makedepends = systemd
+ conflicts = php-pear
+ source = http://php.net/distributions/php-7.1.10.tar.xz
+ md5sums = de80c2f119d2b864c65f114ba3e438f1
+
+pkgname = php-pear-src
+ pkgdesc = PHP Extension and Application Repository
+ depends = php
+ provides = php-pear=1.10.5
+ backup = etc/php/pear.conf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d4a57b15e2a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,127 @@
+# Maintainer: preparationh67 <preparationh67 at gmail.com>
+
+_pkgbase=php
+_phpver=7.1.10
+_pkgname=php-pear
+pkgname=php-pear-src
+pkgver=1.10.5
+pkgrel=1
+pkgdesc="PHP Extension and Application Repository"
+arch=('i686' 'x86_64')
+license=('PHP')
+conflicts=('php-pear')
+url='http://pear.php.net'
+makedepends=('apache' 'c-client' 'postgresql-libs' 'libldap' 'smtp-forwarder'
+ 'sqlite' 'unixodbc' 'net-snmp' 'libzip' 'enchant' 'file' 'freetds'
+ 'libmcrypt' 'tidyhtml' 'aspell' 'libltdl' 'gd' 'icu'
+ 'curl' 'libxslt' 'openssl' 'db' 'gmp' 'systemd')
+
+source=("http://php.net/distributions/${_pkgbase}-${_phpver}.tar.xz")
+
+build() {
+ local _phpconfig="--srcdir=../${_pkgbase}-${_phpver} \
+ --config-cache \
+ --prefix=/usr \
+ --sysconfdir=/etc/${_pkgbase} \
+ --localstatedir=/var \
+ --libdir=/usr/lib/${_pkgbase} \
+ --datarootdir=/usr/share/${_pkgbase} \
+ --datadir=/usr/share/${_pkgbase} \
+ --with-layout=GNU \
+ --with-config-file-path=/etc/${_pkgbase} \
+ --with-config-file-scan-dir=/etc/${_pkgbase}/conf.d \
+ --disable-rpath \
+ --without-pear \
+ "
+
+ local _phpextensions="--enable-bcmath=shared \
+ --enable-calendar=shared \
+ --enable-dba=shared \
+ --enable-exif=shared \
+ --enable-ftp=shared \
+ --enable-gd-native-ttf \
+ --enable-intl=shared \
+ --enable-mbstring \
+ --enable-opcache \
+ --enable-phar=shared \
+ --enable-posix=shared \
+ --enable-shmop=shared \
+ --enable-soap=shared \
+ --enable-sockets=shared \
+ --enable-sysvmsg=shared \
+ --enable-sysvsem=shared \
+ --enable-sysvshm=shared \
+ --enable-zip=shared \
+ --with-bz2=shared \
+ --with-curl=shared \
+ --with-db4=/usr \
+ --with-enchant=shared,/usr \
+ --with-fpm-systemd \
+ --with-freetype-dir=/usr \
+ --with-xpm-dir=/usr \
+ --with-gd=shared,/usr \
+ --with-gdbm \
+ --with-gettext=shared \
+ --with-gmp=shared \
+ --with-iconv=shared \
+ --with-icu-dir=/usr \
+ --with-imap-ssl \
+ --with-imap=shared \
+ --with-kerberos=/usr \
+ --with-jpeg-dir=/usr \
+ --with-vpx-dir=/usr \
+ --with-ldap=shared \
+ --with-ldap-sasl \
+ --with-libzip \
+ --with-mcrypt=shared \
+ --with-mhash \
+ --with-mssql=shared \
+ --with-mysql-sock=/run/mysqld/mysqld.sock \
+ --with-mysql=shared,mysqlnd \
+ --with-mysqli=shared,mysqlnd \
+ --with-openssl=shared \
+ --with-pcre-regex=/usr \
+ --with-pdo-mysql=shared,mysqlnd \
+ --with-pdo-odbc=shared,unixODBC,/usr \
+ --with-pdo-pgsql=shared \
+ --with-pdo-sqlite=shared,/usr \
+ --with-pgsql=shared \
+ --with-png-dir=/usr \
+ --with-pspell=shared \
+ --with-snmp=shared \
+ --with-sqlite3=shared,/usr \
+ --with-tidy=shared \
+ --with-unixODBC=shared,/usr \
+ --with-xmlrpc=shared \
+ --with-xsl=shared \
+ "
+
+ export EXTENSION_DIR=/usr/lib/${_pkgbase}/modules
+ export PEAR_INSTALLDIR=/usr/share/${_pkgbase}/pear
+
+ cd ${srcdir}/${_pkgbase}-${_phpver}
+ # pear
+ mkdir ${srcdir}/build-pear
+ cd ${srcdir}/build-pear
+ ln -sf ../${_pkgbase}-${_phpver}/configure
+ ./configure ${_phpconfig} \
+ --disable-cgi \
+ --with-readline \
+ --enable-pcntl \
+ --with-pear \
+ ${_phpextensions}
+ make
+}
+
+package() {
+ pkgdesc='PHP Extension and Application Repository'
+ depends=("${_pkgbase}")
+ provides=("${_pkgbase}-pear=$pkgver")
+ backup=("etc/${_pkgbase}/pear.conf")
+
+ cd ${srcdir}/build-pear
+ make install-pear INSTALL_ROOT=${pkgdir}
+ rm -rf ${pkgdir}/usr/share/${_pkgbase}/pear/.{channels,depdb,depdblock,filemap,lock,registry}
+
+}
+md5sums=('de80c2f119d2b864c65f114ba3e438f1')