summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwolftankk2015-07-11 16:17:50 +0800
committerwolftankk2015-07-11 16:17:50 +0800
commit902ac780339097562904553f4e336fb057a971ca (patch)
treec848ca6d52931e4fd5f47f6ac7c2342f1dad6992
parentacb61add683239392c28d31c3340c6093ca0c22f (diff)
downloadaur-902ac780339097562904553f4e336fb057a971ca.tar.gz
update pkg sum
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 64d0153af316..702c6887af09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: wolftankk <wolftankk@gmail.com>
pkgname=php-phalcon
pkgver=2.0.4
-pkgrel=1
+pkgrel=2
pkgdesc="Web framework delivered as a C-extension for PHP"
url="http://phalconphp.com"
arch=('x86_64' 'i686')
@@ -15,7 +15,7 @@ source=(
"https://github.com/phalcon/cphalcon/archive/phalcon-v$pkgver.zip"
)
-sha256sums=('97118008d285c288dbaf14e4c3e2257ae8ed899c399336e618ce1685769b7164')
+sha256sums=('1de10df594018efc99434d85429b42923fe33c319a2b995d7296646f58047066')
build() {
cd "$srcdir/cphalcon-phalcon-v$pkgver"
@@ -24,25 +24,25 @@ build() {
export CFLAGS="-march=native -mtune=native -O2 -fomit-frame-pointer"
export CPPFLAGS="-DPHALCON_RELEASE"
echo "int main() {}" > t.c
- gcc $CFLAGS t.c -o t 2> t.t
+ $CC $CFLAGS t.c -o t 2> t.t
if [ $? != 0 ]; then
chmod +x gcccpuopt
BFLAGS=`./gcccpuopt`
export CFLAGS="-O2 -fomit-frame-pointer $BFLAGS"
- gcc $CFLAGS t.c -o t 2> t.t
+ $CC $CFLAGS t.c -o t 2> t.t
if [ $? != 0 ]; then
export CFLAGS="-O2"
fi
fi
- if [ $(gcc -dumpversion | cut -f1 -d.) -ge 4 ]; then
- gcc $CFLAGS -fvisibility=hidden t.c -o t 2> t.t && export CFLAGS="$CFLAGS -fvisibility=hidden"
+ if [ $($CC -dumpversion | cut -f1 -d.) -ge 4 ]; then
+ $CC $CFLAGS -fvisibility=hidden t.c -o t 2> t.t && export CFLAGS="$CFLAGS -fvisibility=hidden"
fi
#gcc $CFLAGS -flto t.c -o t 2> t.t && { export CFLAGS="$CFLAGS -flto"; export LDFLAGS="$LDFLAGS $CFLAGS"; }
rm -f t.t t.c t
#cd dir
- cd "$srcdir/cphalcon-phalcon-v$pkgver/ext"
+ cd "$srcdir/cphalcon-phalcon-v$pkgver/build/$_arch"
#Clean current compilation
if [ -f Makefile ]; then
@@ -56,7 +56,7 @@ build() {
}
package() {
- cd "$srcdir/cphalcon-phalcon-v$pkgver/ext"
+ cd "$srcdir/cphalcon-phalcon-v$pkgver/build/$_arch"
make INSTALL_ROOT="$pkgdir" install
echo 'extension=phalcon.so' > phalcon.ini