summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoris Steyn2015-12-20 22:36:44 +0100
committerJoris Steyn2015-12-20 22:40:27 +0100
commit9381c22e824a6939013b86de876ee68e493e7273 (patch)
tree22bd4ebfbe78fc56f718c1d7a270f1f856fd20ca
downloadaur-9381c22e824a6939013b86de876ee68e493e7273.tar.gz
Initial commit based on old php-phd package
Old source: pkgbuild.com/git/aur-mirror.git/tree/php-phd/PKGBUILD
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD50
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..92416eb8fb5d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sun Dec 20 21:40:22 UTC 2015
+pkgbase = php-phd
+ pkgdesc = The PHP DocBook renderer (includes pman build scripts)
+ pkgver = 1.1.10
+ pkgrel = 1
+ url = https://wiki.php.net/doc/phd/
+ arch = any
+ license = PHP
+ makedepends = git
+ depends = php
+ depends = php-sqlite
+ source = git://git.php.net/phd.git#tag=RELEASE_1_1_10
+ md5sums = SKIP
+
+pkgname = php-phd
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d35636f1a47b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+/phd
+/*xz \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..073e2ce86af1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Joris Steyn <joris@j0r1s.nl>
+# Contributor: Techlive Zheng <techlivezheng-at-gmail.com>
+# This package is a build depencency for php-manpages-svn
+
+pkgname=php-phd
+pkgver=1.1.10
+pkgrel=1
+pkgdesc='The PHP DocBook renderer (includes pman build scripts)'
+arch=('any')
+url='https://wiki.php.net/doc/phd/'
+license=('PHP')
+depends=('php' 'php-sqlite')
+makedepends=('git')
+
+source=('git://git.php.net/phd.git#tag=RELEASE_1_1_10')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir"/phd
+ git describe --tags --always | sed -E 's/^RELEASE_//;s/([^-]*-g)/r\1/;s/_/./g;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir"
+
+ # todo: optionally allow dependencies for creating PEAR packages,
+ # not doing this by default because the whole point of this is
+ # generating the manpages ourselves and without the ambiguous pman
+ # wrapper.
+ #if [ ! -d fakepear ]; then
+ # updating the channel means having more privileges than we
+ # really want to have while packaging, so skip this for now
+ #pear channel-update doc.php.net
+
+ # this will install the package in the fakeroot environment
+ # so pear isn't really needed after building the package
+ #pear config-set preferred_state beta
+ #pear install --packagingroot "$srcdir"/fakepear PEAR_PackageFileManager2
+ #fi
+}
+
+package() {
+ install -d "$pkgdir"/usr/share/php/phd
+ cp -r "$srcdir"/phd/* "$pkgdir"/usr/share/php/phd/
+
+ # only needed when generating pman
+ #cp -r "$srcdir"/fakepear "$pkgdir"/usr/share/php/phd/fakepear
+}
+
+# vim:set ts=2 sw=2 et: