summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-06-28 17:24:18 +0200
committerGoliathLabs2020-06-28 17:24:18 +0200
commit6797e7b362661fad079029865c402d4598f7443e (patch)
treea980b0fbcf7da6838fd9863c08bc1e51a760982b
parent2318e368fe02701259fb5ebe38770f0380a96bcd (diff)
downloadaur-6797e7b362661fad079029865c402d4598f7443e.tar.gz
Updated: 4.0.3
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 16 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 58ddf8bedc4d..9aa1604ac2b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = php-rdkafka
- pkgdesc = This extension is a librdkafka binding providing a working client for Kafka 0.8, 0.9, 0.10
- pkgver = 2.0.1
- pkgrel = 2
+ pkgdesc = PHP-rdkafka is a thin librdkafka binding providing a working PHP 5 / PHP 7 Kafka client
+ pkgver = 4.0.3
+ pkgrel = 1
url = https://github.com/arnaud-lb/php-rdkafka
arch = i686
arch = x86_64
- license = MIT License
+ license = MIT
depends = php
- depends = librdkafka-git
+ depends = librdkafka
backup = etc/php/conf.d/rdkafka.ini
- source = http://pecl.php.net/get/rdkafka-2.0.1.tgz
- sha256sums = 43a3704198f7d8ae23f6ed06d2d28ae4d52bae0f93f484aa5d61d5d60f809eee
+ source = https://pecl.php.net/get/rdkafka-4.0.3.tgz
+ md5sums = 766efc78dd01a4a65c8200e4abee957d
pkgname = php-rdkafka
diff --git a/PKGBUILD b/PKGBUILD
index 8313992b6e28..e42e9869786f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
-# Maintainer: 吕海涛 <aur@lvht.net>
+# Maintainer: Felix Golatofski <contact@xdfr.de>
+# Contributor: 吕海涛 <aur@lvht.net>
pkgname=php-rdkafka
_extname=rdkafka
-pkgver=2.0.1
-pkgrel=2
-pkgdesc="This extension is a librdkafka binding providing a working client for Kafka 0.8, 0.9, 0.10"
+pkgver=4.0.3
+pkgrel=1
+pkgdesc="PHP-rdkafka is a thin librdkafka binding providing a working PHP 5 / PHP 7 Kafka client"
arch=("i686" "x86_64")
url="https://github.com/arnaud-lb/php-rdkafka"
-license=('MIT License')
-depends=('php' 'librdkafka-git')
-source=("http://pecl.php.net/get/$_extname-$pkgver.tgz")
+license=('MIT')
+depends=('php' 'librdkafka')
+source=("https://pecl.php.net/get/$_extname-$pkgver.tgz")
backup=("etc/php/conf.d/$_extname.ini")
-packager="吕海涛 <aur@lvht.net>"
+md5sums=('766efc78dd01a4a65c8200e4abee957d')
build() {
cd "$srcdir/$_extname-$pkgver"
@@ -28,5 +29,3 @@ package() {
chmod 0644 "$pkgdir/etc/php/conf.d/$_extname.ini"
install -m0755 -D ".libs/$_extname.so" "$pkgdir$(php-config --extension-dir)/$_extname.so"
}
-
-sha256sums=('43a3704198f7d8ae23f6ed06d2d28ae4d52bae0f93f484aa5d61d5d60f809eee')