summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey Manukhin2015-07-14 22:29:21 -0700
committerAlexey Manukhin2015-07-14 22:29:21 -0700
commit1d549d24752b16ad41f2f64915c069859ae6216e (patch)
tree8eec6eb64ebfb5b3805acfffe8d8f0034c0570c1
downloadaur-1d549d24752b16ad41f2f64915c069859ae6216e.tar.gz
initial commit: runkit for php 5.6.+
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b02d44ab128
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = php-runkit
+ pkgdesc = Runkit is set of tools which allowes to do what Reflection does not allow. Usefull for unit tests.
+ pkgver = git
+ pkgrel = 1
+ url = https://github.com/zenovich/runkit
+ arch = x86_64
+ arch = i686
+ license = PHP
+ makedepends = php
+ depends = php
+ source = git+https://github.com/zenovich/runkit.git
+ source = https://github.com/zenovich/runkit/pull/73.diff
+ md5sums = SKIP
+ md5sums = 768c220680f414b1b3858f0d856e6a40
+
+pkgname = php-runkit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d6992b09715
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Alexey Manukhin <axxapy@gmail.com>
+
+pkgname=php-runkit
+pkgdesc='Runkit is set of tools which allowes to do what Reflection does not allow. Usefull for unit tests.'
+pkgver=git
+pkgrel=1
+
+arch=('x86_64' 'i686')
+license=('PHP')
+url=https://github.com/zenovich/runkit
+
+makedepends=('php')
+source=("git+https://github.com/zenovich/runkit.git" "https://github.com/zenovich/runkit/pull/73.diff")
+md5sums=('SKIP' '768c220680f414b1b3858f0d856e6a40')
+depends=('php')
+
+build() {
+ cd ${srcdir}/runkit || return 1
+ patch -p1 < $startdir/73.diff
+ phpize || return 1
+ ./configure ${peclconfig}|| return 1
+ make || return 1
+}
+
+package_php-runkit() {
+ install -d -m755 ${pkgdir}/usr/lib/php/modules/
+ install -m644 ${srcdir}/runkit/modules/runkit.so ${pkgdir}/usr/lib/php/modules//runkit.so
+
+ echo 'extension=runkit.so' > ${startdir}/runkit.ini || return 1
+ echo 'runkit.internal_override=1' >> ${startdir}/runkit.ini || return 1
+ install -D -m 644 $startdir/runkit.ini ${pkgdir}/etc/php/conf.d/runkit.ini || return 1
+}
+