summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Galeotti2015-06-08 15:36:45 -0300
committerBruno Galeotti2015-06-08 15:36:45 -0300
commit74775bf184be779d525f90425201c7a051747e8b (patch)
tree946b3452c39566da3174315d7e21d6754cd5a53a
downloadaur-74775bf184be779d525f90425201c7a051747e8b.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f7005f1a3e16
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = php-semver-checker
+ pkgdesc = Compares two source sets and determines the appropriate semantic versioning to apply.
+ pkgver = 0.6.2
+ pkgrel = 1
+ url = https://github.com/tomzx/php-semver-checker
+ arch = any
+ license = MIT
+ makedepends = php-box
+ makedepends = php-composer
+ depends = php>=5.4.0
+ source = https://github.com/tomzx/php-semver-checker/archive/v0.6.2.tar.gz
+ sha512sums = c9b44353de4b8c63997e7dc5631edbc15ed5f4e4e43bf1af7456d81b316fd36701f2a746ad72385a105ab81a49531147b60791068edfa8e1221c21c756fe20cd
+
+pkgname = php-semver-checker
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab2ec78c982a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Mantainer: Bruno Galeotti <bgaleotti at gmail dot com>
+
+pkgname=php-semver-checker
+pkgver=0.6.2
+pkgrel=1
+pkgdesc="Compares two source sets and determines the appropriate semantic versioning to apply."
+url="https://github.com/tomzx/php-semver-checker"
+license="MIT"
+arch=("any")
+depends=("php>=5.4.0")
+makedepends=("php-box" "php-composer")
+source=("https://github.com/tomzx/${pkgname}/archive/v${pkgver}.tar.gz")
+#source=("${pkgname}::git+https://github.com/tomzx/${pkgname}.git")
+sha512sums=('c9b44353de4b8c63997e7dc5631edbc15ed5f4e4e43bf1af7456d81b316fd36701f2a746ad72385a105ab81a49531147b60791068edfa8e1221c21c756fe20cd')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ composer install --prefer-dist --no-dev
+ sed -i '/git-version/d' box.json
+ sed -i "s/@package_version@/${pkgver}/g" src/PHPSemVerChecker/Console/Application.php
+ php-box build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m755 "${pkgname}.phar" "${pkgdir}/usr/share/webapps/bin/${pkgname}.phar"
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/usr/share/webapps/bin/${pkgname}.phar" "${pkgdir}/usr/bin/${pkgname}"
+}