summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre Schmitz2015-06-13 13:32:41 +0200
committerPierre Schmitz2015-06-13 13:32:41 +0200
commit364626d243ba9be0a02f1d9eb7cba0eaedc8e718 (patch)
treed4fb99a8ab0bab882eb659869a86a336076c2917
downloadaur-364626d243ba9be0a02f1d9eb7cba0eaedc8e718.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD42
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b19b242a73c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by makepkg 4.2.1
+# Sun Mar 29 06:12:24 UTC 2015
+pkgbase = php-suhosin
+ pkgdesc = An advanced protection system for PHP installations
+ pkgver = 0.9.37.1
+ pkgrel = 1
+ url = http://suhosin.org/
+ arch = i686
+ arch = x86_64
+ license = PHP
+ checkdepends = php-cgi
+ depends = php
+ backup = etc/php/conf.d/suhosin.ini
+ source = http://download.suhosin.org/suhosin-0.9.37.1.tar.gz
+ sha1sums = 9de7a89ef7d336501a41f452fd3936ae66f63a6e
+
+pkgname = php-suhosin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..674739ff9184
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# $Id: PKGBUILD 146960 2012-01-19 17:53:37Z pierre $
+# Maintainer: Pierre Schmitz <pierre@archlinux.de>
+
+pkgname=php-suhosin
+pkgver=0.9.37.1
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc='An advanced protection system for PHP installations'
+url='http://suhosin.org/'
+license=('PHP')
+source=("http://download.suhosin.org/suhosin-${pkgver}.tar.gz"
+# "http://download.suhosin.org/suhosin-${pkgver}.tar.gz.sig"
+ )
+depends=('php')
+checkdepends=('php-cgi')
+backup=('etc/php/conf.d/suhosin.ini')
+sha1sums=('9de7a89ef7d336501a41f452fd3936ae66f63a6e'
+# 'SKIP'
+)
+# validpgpkeys=('E027452AFAB2A52F18AB6363B12D0447319F1ADB')
+
+build() {
+ cd ${srcdir}/suhosin-${pkgver}
+ phpize
+ ./configure --prefix=/usr --enable-suhosin
+ make
+}
+
+check() {
+ cd ${srcdir}/suhosin-${pkgver}
+ export NO_INTERACTION=1
+ make test
+ echo
+}
+
+package() {
+ cd ${srcdir}/suhosin-${pkgver}
+ make INSTALL_ROOT=${pkgdir} install
+ # disable by default
+ sed -i 's|extension = suhosin.so|;extension=suhosin.so|g' suhosin.ini
+ install -D -m644 suhosin.ini ${pkgdir}/etc/php/conf.d/suhosin.ini
+}