summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2016-10-29 03:10:45 -0400
committerJames An2016-10-29 03:10:45 -0400
commit3e7806d514d57edc18837f486e30974a67d2509c (patch)
tree1844dfd8bd04ee7523061bed9fbdbc08a144440d
parenta8f6e8363f08514e1ebbb8729a231f60c801b0ef (diff)
downloadaur-3e7806d514d57edc18837f486e30974a67d2509c.tar.gz
Forked from AUR package, php-suhosin, and updated to new suhosin7 package.
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore27
-rw-r--r--PKGBUILD48
3 files changed, 59 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d85460e2aa15..b2b3e0b2402c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = php-suhosin
+pkgbase = php-suhosin7-git
pkgdesc = An advanced protection system for PHP installations
- pkgver = 0.9.38
+ pkgver = 0.10.0dev.r58.ge55e273
pkgrel = 1
url = http://suhosin.org/
arch = i686
@@ -8,11 +8,11 @@ pkgbase = php-suhosin
license = PHP
checkdepends = php-cgi
depends = php
- backup = etc/php/conf.d/suhosin.ini
- source = https://download.suhosin.org/suhosin-0.9.38.tar.gz
- source = https://download.suhosin.org/suhosin-0.9.38.tar.gz.sig
- sha1sums = 20af6379c0ff9879c5ed69452a6c38b7b3e76748
- sha1sums = SKIP
+ provides = php-suhosin7=0.10.0dev.r58.ge55e273
+ conflicts = php-suhosin7
+ backup = etc/php/conf.d/$__pkgname.ini
+ source = php-suhosin7::git+https://github.com/sektioneins/suhosin7.git
+ md5sums = SKIP
-pkgname = php-suhosin
+pkgname = php-suhosin7-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..43316bc3c124
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,27 @@
+# From: https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+
+*.tar
+*.tar.*
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+# makepkg working folders
+pkg
+src
+
+#
+# Additional ignore patterns:
+#
+
+# Source files
+*.deb
+*.gem
+*.out
+*.rpm
+*.html
+
+# Ignore package source folders
+*/*
diff --git a/PKGBUILD b/PKGBUILD
index d6446e80bdec..1eb8974fa263 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,40 @@
-# $Id: PKGBUILD 146960 2012-01-19 17:53:37Z pierre $
-# Maintainer: Pierre Schmitz <pierre@archlinux.de>
+# Maintainer: James An <james@jamesan.ca>
+# Contributor: Pierre Schmitz <pierre@archlinux.de>
-pkgname=php-suhosin
-pkgver=0.9.38
+pkgname=php-suhosin7-git
+_pkgname=${pkgname%-git}
+__pkgname=${_pkgname#php-}
+pkgver=0.10.0dev.r58.ge55e273
pkgrel=1
-arch=('i686' 'x86_64')
pkgdesc='An advanced protection system for PHP installations'
+arch=('i686' 'x86_64')
url='http://suhosin.org/'
license=('PHP')
-source=("https://download.suhosin.org/suhosin-${pkgver}.tar.gz"
- "https://download.suhosin.org/suhosin-${pkgver}.tar.gz.sig")
depends=('php')
checkdepends=('php-cgi')
-backup=('etc/php/conf.d/suhosin.ini')
-sha1sums=('20af6379c0ff9879c5ed69452a6c38b7b3e76748'
- 'SKIP')
-validpgpkeys=('E027452AFAB2A52F18AB6363B12D0447319F1ADB')
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname")
+backup=('etc/php/conf.d/$__pkgname.ini')
+source=("$_pkgname"::"git+https://github.com/sektioneins/$__pkgname.git")
+md5sums=('SKIP')
build() {
- cd ${srcdir}/suhosin-${pkgver}
- phpize
- ./configure --prefix=/usr --enable-suhosin
- make
+ cd $_pkgname
+
+ phpize
+ ./configure --prefix=/usr --enable-$__pkgname
+ make
}
check() {
- cd ${srcdir}/suhosin-${pkgver}
- export NO_INTERACTION=1
- export REPORT_EXIT_STATUS=1
- make test
+ cd $_pkgname
+
+ NO_INTERACTION=1 REPORT_EXIT_STATUS=1 make -k test
}
package() {
- cd ${srcdir}/suhosin-${pkgver}
- make INSTALL_ROOT=${pkgdir} install
- # disable by default
- sed -i 's|extension = suhosin.so|;extension=suhosin.so|g' suhosin.ini
- install -D -m644 suhosin.ini ${pkgdir}/etc/php/conf.d/suhosin.ini
+ cd $_pkgname
+
+ make INSTALL_ROOT=$pkgdir install
+ install -D -m644 $__pkgname.ini $pkgdir/etc/php/conf.d/$__pkgname.ini
}