summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Richards2015-08-07 13:06:05 -0400
committerTom Richards2015-08-07 13:06:05 -0400
commitd91999945c54301066e7b40b02c752a0d2d36006 (patch)
tree1af2eb106cd64cd68e4af122aaa7fbc130e1b750
downloadaur-d91999945c54301066e7b40b02c752a0d2d36006.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore5
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD31
4 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c53692657ff1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = php-vld
+ pkgdesc = The Vulcan Logic Dumper hooks into the Zend Engine and dumps all the opcodes (execution units) of a script.
+ pkgver = 0.13.0
+ pkgrel = 1
+ url = http://derickrethans.nl/projects.html#vld
+ arch = x86
+ arch = x86_64
+ license = BSD
+ makedepends = php
+ source = https://github.com/derickr/vld/archive/VLD_0_13_0.tar.gz
+ sha256sums = 9b8eaac66309d4a869f17e72862baf90af13766ecf30975288a4bb1c944ed57a
+
+pkgname = php-vld
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..aa5e44415403
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!LICENSE
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..7e11b2109176
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) 2015 Tom Richards
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3df8c4785ac5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Tom Richards <tom@tomrichards.net>
+# https://github.com/t-richards/aur-vld
+_pkgname=vld
+_pkgver=VLD_0_13_0
+pkgname=php-vld
+pkgver=0.13.0
+pkgrel=1
+pkgdesc="The Vulcan Logic Dumper hooks into the Zend Engine and dumps all the opcodes (execution units) of a script."
+arch=('x86' 'x86_64')
+url="http://derickrethans.nl/projects.html#vld"
+license=('BSD')
+makedepends=('php')
+source=("https://github.com/derickr/vld/archive/VLD_0_13_0.tar.gz")
+sha256sums=('9b8eaac66309d4a869f17e72862baf90af13766ecf30975288a4bb1c944ed57a')
+
+build() {
+ cd "$_pkgname-$_pkgver"
+ phpize
+ ./configure
+ make
+}
+
+package() {
+ cd "$_pkgname-$_pkgver"
+
+ # PHP module
+ install -Dm755 modules/vld.so "$pkgdir/usr/lib/php/modules/vld.so"
+
+ # License
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}