summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjgmdev2016-10-06 04:02:11 -0400
committerjgmdev2016-10-06 04:02:11 -0400
commitce1d58eca4deca1a543048b617f701c2893692e5 (patch)
treea5459061bffc0b1f1659e36a752764269749cb1e
parent5a12088e9c57361142a1dafa8020558355dead7c (diff)
downloadaur-ce1d58eca4deca1a543048b617f701c2893692e5.tar.gz
Build wxWidgets using gtk2 since the gtk3 port has some sizer issues.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 459a1ccc30d1..1f72c7054925 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Thu Oct 6 07:42:24 UTC 2016
+# Thu Oct 6 08:01:08 UTC 2016
pkgbase = php-wxwidgets-git
pkgdesc = PHP bindings to the cross-platform wxWidgets GUI Toolkit library.
pkgver = v3.0.2.0.r208.g0560d4f
@@ -16,8 +16,8 @@ pkgbase = php-wxwidgets-git
makedepends = sdl
makedepends = sdl_sound
makedepends = php56
- makedepends = webkitgtk
- depends = gtk3
+ makedepends = webkitgtk2
+ depends = gtk2
depends = libgl
depends = libxxf86vm
depends = libsm
@@ -25,7 +25,7 @@ pkgbase = php-wxwidgets-git
depends = sdl_sound
depends = gstreamer
depends = php56
- depends = webkitgtk
+ depends = webkitgtk2
source = http://downloads.sourceforge.net/wxwindows/wxWidgets-3.0.2.tar.bz2
source = git://github.com/wxphp/wxphp.git
source = make-abicheck-non-fatal.patch
diff --git a/PKGBUILD b/PKGBUILD
index 78febbe6aa79..5e4ed300a83b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,8 @@ arch=('i686' 'x86_64')
url="http://wxphp.org"
install=php-wxwidgets-git.install
license=('PHP')
-depends=('gtk3' 'libgl' 'libxxf86vm' 'libsm' 'sdl' 'sdl_sound' 'gstreamer' 'php56' 'webkitgtk')
-makedepends=('mesa' 'glu' 'libxt' 'gstreamer' 'sdl' 'sdl_sound' 'php56' 'webkitgtk')
+depends=('gtk2' 'libgl' 'libxxf86vm' 'libsm' 'sdl' 'sdl_sound' 'gstreamer' 'php56' 'webkitgtk2')
+makedepends=('mesa' 'glu' 'libxt' 'gstreamer' 'sdl' 'sdl_sound' 'php56' 'webkitgtk2')
source=(
"http://downloads.sourceforge.net/wxwindows/wxWidgets-${_pkgver}.tar.bz2"
"git://github.com/wxphp/${_gitname}.git"
@@ -48,7 +48,7 @@ build() {
CFLAGS="-fPIC -O2 -Wall -W" CXXFLAGS="-fPIC -O2" \
./configure --prefix="${srcdir}/wxWidgets-${_pkgver}-static" \
- --with-{gtk=3,libjpeg=sys,libpng=sys,libtiff=sys,libxpm=sys,opengl,regex=builtin,sdl} \
+ --with-{gtk=2,libjpeg=sys,libpng=sys,libtiff=sys,libxpm=sys,opengl,regex=builtin,sdl} \
--enable-{graphics_ctx,unicode,monolithic} \
--disable-shared