summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElmar Klausmeier2023-01-13 19:40:41 +0100
committerElmar Klausmeier2023-01-13 19:40:41 +0100
commit868d0ac8edd17f269479b180ed7523dee7189586 (patch)
treebcf492b1de5532267f09e77fbab81ac3c8ced34d
parent38e71690594400a29cb52fa37d447cbcd358d19e (diff)
downloadaur-868d0ac8edd17f269479b180ed7523dee7189586.tar.gz
New maintainer, updated to XHProf version 2.3.9
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD77
2 files changed, 46 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index acdec3209e06..a4241a90024c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = php-xhprof
pkgdesc = A Hierarchical Profiler for PHP
- pkgver = 0.9.10
+ pkgver = 2.3.9
pkgrel = 1
url = https://github.com/phacility/xhprof/tree/experimental
- install = php-xhprof.install
arch = i686
arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = Apache
depends = php
optdepends = graphviz: to generate callgraphs in reports
- backup = etc/php/conf.d/xhprof.ini
- source = https://github.com/phacility/xhprof/archive/dab44f76da5c8a0d4f1339f7d2ea2bc42408e8e9.zip
- sha512sums = c8620e34d0a3816740e28efbbbbfd2c85e50dcbee907e54b86afdb1b2c49f6896203b8a84471def56cce105aef17937bf13544f35b70dab4a7f0ae1c071cb67f
+ source = https://pecl.php.net/get/xhprof-2.3.9.tgz
+ sha512sums = 38a2609d961d908c6a4b5d1ff2085ffdad4a5f7d277705c826ae19e215660802528d606c5ee052f2e65255a7a85b2a9cb9038f4785c730ec468fc76dc7bcf5de
pkgname = php-xhprof
-
diff --git a/PKGBUILD b/PKGBUILD
index 7dc1963d3468..8dc8aaea9487 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,63 +1,66 @@
-# Maintainer: Kenneth Endfinger <kaendfinger@gmail.com>
+# Maintainer: Elmar Klausmeier <Elmar.Klausmeier@gmail.com>
+# Previous maintainer: Kenneth Endfinger <kaendfinger@gmail.com>
# Contributor: Sebastien Duquette <ekse.0x@gmail.com>
# Contributor: Martin Kozák <martinkozak@martinkozak.net>
pkgname=php-xhprof
-pkgver=0.9.10
+pkgver=2.3.9
pkgrel=1
-__commit="dab44f76da5c8a0d4f1339f7d2ea2bc42408e8e9"
pkgdesc="A Hierarchical Profiler for PHP"
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/phacility/xhprof/tree/experimental"
license=('Apache')
depends=('php')
makedepends=()
optdepends=('graphviz: to generate callgraphs in reports')
-backup=('etc/php/conf.d/xhprof.ini')
+# backup=('etc/php/conf.d/xhprof.ini')
options=()
-install=php-xhprof.install
-source=("https://github.com/phacility/xhprof/archive/${__commit}.zip")
-sha512sums=('c8620e34d0a3816740e28efbbbbfd2c85e50dcbee907e54b86afdb1b2c49f6896203b8a84471def56cce105aef17937bf13544f35b70dab4a7f0ae1c071cb67f')
+#install=php-xhprof.install
+source=("https://pecl.php.net/get/xhprof-${pkgver}.tgz")
+sha512sums=('38a2609d961d908c6a4b5d1ff2085ffdad4a5f7d277705c826ae19e215660802528d606c5ee052f2e65255a7a85b2a9cb9038f4785c730ec468fc76dc7bcf5de')
prepare() {
- cd "$srcdir/xhprof-${__commit}/extension/"
+ cd "$srcdir/xhprof-${pkgver}/extension/"
- phpize || return 1
- ./configure --prefix=/usr --with-php-config=$(which php-config)
+ phpize || return 1
+ ./configure --prefix=/usr --with-php-config=$(which php-config)
}
build() {
- cd "$srcdir/xhprof-${__commit}/extension/"
- make || return 1
+ cd "$srcdir/xhprof-${pkgver}/extension/"
+ make || return 1
+ NO_INTERACTION=1 make test || return 1
}
package() {
- cd "$srcdir/xhprof-${__commit}/extension/"
- make INSTALL_ROOT="$pkgdir/" install
- echo ';extension=xhprof.so' > xhprof.ini
- install -D -m644 xhprof.ini "$pkgdir/etc/php/conf.d/xhprof.ini"
-
- # HTML Report interface
- cd ".."
- mkdir -p $pkgdir/usr/share/webapps/xhprof/
- cp -ra xhprof_html $pkgdir/usr/share/webapps/xhprof/
- cp -ra xhprof_lib $pkgdir/usr/share/webapps/xhprof/
-
- # apache
- mkdir -p $pkgdir/etc/httpd/conf/extra/
- cat >$pkgdir/etc/httpd/conf/extra/xhprof.conf <<EOF
- Alias /xhprof "/usr/share/webapps/xhprof/xhprof_html"
- <Directory "/usr/share/webapps/xhprof/xhprof_html">
- AllowOverride All
- Options FollowSymlinks
- Order allow,deny
- Allow from all
- php_admin_value open_basedir "/srv/:/tmp/:/usr/share/webapps/:/etc/webapps:/usr/share/pear/"
- </Directory>
-EOF
+ cd "$srcdir/xhprof-${pkgver}/extension/"
+ make INSTALL_ROOT="$pkgdir/" install
+ # xhprof.ini not really needed, therefore commented out here
+ #echo ';extension=xhprof.so' > xhprof.ini
+ #install -D -m644 xhprof.ini "$pkgdir/etc/php/conf.d/xhprof.ini"
+
+ # HTML Report interface: copy JavaScript + PHP
+ cd ..
+ mkdir -p $pkgdir/usr/share/webapps/xhprof/
+ cp -ra xhprof_html $pkgdir/usr/share/webapps/xhprof/
+ cp -ra xhprof_lib $pkgdir/usr/share/webapps/xhprof/
+
+ # Apache web-server config stuff. Left here in comments.
+ # I prefer Hiawatha web-server, others might prefer NGINX, etc.
+# mkdir -p $pkgdir/etc/httpd/conf/extra/
+# cat >$pkgdir/etc/httpd/conf/extra/xhprof.conf <<EOF
+# Alias /xhprof "/usr/share/webapps/xhprof/xhprof_html"
+# <Directory "/usr/share/webapps/xhprof/xhprof_html">
+# AllowOverride All
+# Options FollowSymlinks
+# Order allow,deny
+# Allow from all
+# php_admin_value open_basedir "/srv/:/tmp/:/usr/share/webapps/:/etc/webapps:/usr/share/pear/"
+# </Directory>
+#EOF
}
-#Y vim:set ts=2 sw=2 et:
+