summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene Lamskoy2022-11-05 23:53:28 +0200
committerEugene Lamskoy2022-11-05 23:53:28 +0200
commit24ddae14eaf4433267406ed79acecffcf1516be0 (patch)
tree0b9ccb2be0bc2a6b9ac611837688301e5360f35b
parentc4afb196fbad662598b6c12c3a96e928b5a7900e (diff)
downloadaur-24ddae14eaf4433267406ed79acecffcf1516be0.tar.gz
Fixed openssl 3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
-rw-r--r--openssl-sslv3-consts.patch12
3 files changed, 22 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3dd0e6b663fb..39a07037b4e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
-# Generated by makepkg 6.0.1
-# Fri Feb 18 11:11:55 UTC 2022
+# Generated by makepkg 6.0.2
+# Sat Nov 5 21:51:30 UTC 2022
pkgbase = php55
pkgdesc = PHP 5.5.38 compiled as to not conflict with mainline php
pkgver = 5.5.38
- pkgrel = 11
+ pkgrel = 12
url = http://www.php.net
arch = x86_64
license = PHP
@@ -72,6 +72,7 @@ pkgbase = php55
source = https://php.net/distributions/php-5.5.38.tar.xz
source = php55-phar-names.patch
source = openssl-1.0.patch
+ source = openssl-sslv3-consts.patch
source = fpm-numeric-uid-gid.patch
source = fpm-reload-sighup.patch
source = mysql-socket-php5.3.patch
@@ -92,6 +93,7 @@ pkgbase = php55
sha256sums = cb527c44b48343c8557fe2446464ff1d4695155a95601083e5d1f175df95580f
sha256sums = 70e3cc00d954fa2b466a0e8f356c68bbb1e92b36304deaffd34c53cb6ae5e979
sha256sums = 8a5e1a2a563c38f237b0ed735918ecf82c30edd3f7beae5d99be041585901d27
+ sha256sums = aecd8dff7022e956718407a5b98dec19acdceef08b0a58e7266b483bc3845de6
sha256sums = d175f0c14fdb22855090c93f76e18f04320d7bf15afc057ffde947f9bb361242
sha256sums = f5ae925036744a5e88cea2698879aea0498e1e23aee7801923d90f16be383908
sha256sums = 12f4e3aeab72e7d24221c07b64106c496c2e300518682bd301351dc9fa6ab3cf
diff --git a/PKGBUILD b/PKGBUILD
index 76b1b3a23716..e3ee1d12d73a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@
_phpbase="55"
_suffix=""
pkgver="5.5.38"
-pkgrel="11"
+pkgrel="12"
pkgbase="php55"
pkgdesc="PHP 5.5.38 compiled as to not conflict with mainline php"
_cppflags=" -DU_USING_ICU_NAMESPACE=1 -DOPENSSL_NO_SSL3=1 -DOPENSSL_NO_SSL2=1 -DU_DEFINE_FALSE_AND_TRUE=1 "
@@ -134,6 +134,7 @@ source=(
"https://php.net/distributions/php-${pkgver}.tar.xz"
"php55-phar-names.patch"
"openssl-1.0.patch"
+ "openssl-sslv3-consts.patch"
"fpm-numeric-uid-gid.patch"
"fpm-reload-sighup.patch"
"mysql-socket-php5.3.patch"
@@ -150,8 +151,6 @@ source=(
)
depends=(
)
-checkdepends=(
-)
makedepends=(
"acl"
"libtool"
@@ -214,6 +213,7 @@ arch=(
_patches=(
"php55-phar-names.patch"
"openssl-1.0.patch"
+ "openssl-sslv3-consts.patch"
"fpm-numeric-uid-gid.patch"
"fpm-reload-sighup.patch"
"mysql-socket-php5.3.patch"
@@ -307,7 +307,7 @@ _phpconfig="\
--libdir=/usr/lib/php${_phpbase}${_suffix} \
--datadir=/usr/share/php${_phpbase}${_suffix} \
--program-suffix=${_phpbase}${_suffix} \
- --with-config-file-scan-dir=/${_build_conf_d}
+ --with-config-file-scan-dir=/${_build_conf_d} \
--enable-filter \
--with-pear \
--enable-session \
@@ -1548,6 +1548,7 @@ sha256sums=('e6b8530d747000eebb0089249ec70a3b14add7b501337046700544883f62b17b'
'cb527c44b48343c8557fe2446464ff1d4695155a95601083e5d1f175df95580f'
'70e3cc00d954fa2b466a0e8f356c68bbb1e92b36304deaffd34c53cb6ae5e979'
'8a5e1a2a563c38f237b0ed735918ecf82c30edd3f7beae5d99be041585901d27'
+ 'aecd8dff7022e956718407a5b98dec19acdceef08b0a58e7266b483bc3845de6'
'd175f0c14fdb22855090c93f76e18f04320d7bf15afc057ffde947f9bb361242'
'f5ae925036744a5e88cea2698879aea0498e1e23aee7801923d90f16be383908'
'12f4e3aeab72e7d24221c07b64106c496c2e300518682bd301351dc9fa6ab3cf'
diff --git a/openssl-sslv3-consts.patch b/openssl-sslv3-consts.patch
new file mode 100644
index 000000000000..f8075216683b
--- /dev/null
+++ b/openssl-sslv3-consts.patch
@@ -0,0 +1,12 @@
+--- a/ext/openssl/openssl.c
++++ b/ext/openssl/openssl.c
+@@ -1482,7 +1482,9 @@
+ REGISTER_LONG_CONSTANT("PKCS7_NOSIGS", PKCS7_NOSIGS, CONST_CS|CONST_PERSISTENT);
+
+ REGISTER_LONG_CONSTANT("OPENSSL_PKCS1_PADDING", RSA_PKCS1_PADDING, CONST_CS|CONST_PERSISTENT);
++#ifdef RSA_SSLV23_PADDING
+ REGISTER_LONG_CONSTANT("OPENSSL_SSLV23_PADDING", RSA_SSLV23_PADDING, CONST_CS|CONST_PERSISTENT);
++#endif
+ REGISTER_LONG_CONSTANT("OPENSSL_NO_PADDING", RSA_NO_PADDING, CONST_CS|CONST_PERSISTENT);
+ REGISTER_LONG_CONSTANT("OPENSSL_PKCS1_OAEP_PADDING", RSA_PKCS1_OAEP_PADDING, CONST_CS|CONST_PERSISTENT);
+