summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene Lamskoy2022-02-01 19:38:51 +0200
committerEugene Lamskoy2022-02-01 19:38:51 +0200
commitf0dc309c83e367a41d706af5a006918445600674 (patch)
treea147f104bdf67d01fc4b954e220748eed8547a98
parentedac45efe746cad8c125bc7f4d2c007194a00a84 (diff)
downloadaur-f0dc309c83e367a41d706af5a006918445600674.tar.gz
Dependencies
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
2 files changed, 35 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7b3053fc1e7..c083996b0fa2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by makepkg 6.0.1
-# Mon Jan 24 19:40:09 UTC 2022
+# Tue Feb 1 16:26:59 UTC 2022
pkgbase = php55
pkgdesc = PHP 5.5.38 compiled as to not conflict with mainline php
pkgver = 5.5.38
- pkgrel = 10
+ pkgrel = 11
url = http://www.php.net
arch = x86_64
license = PHP
@@ -51,6 +51,11 @@ pkgbase = php55
makedepends = recode
makedepends = aspell
makedepends = enchant
+ makedepends = libvoikko
+ makedepends = hspell
+ makedepends = hunspell
+ makedepends = nuspell
+ makedepends = aspell
makedepends = icu
makedepends = curl
makedepends = net-snmp
@@ -181,6 +186,7 @@ pkgname = php55-xml
pkgname = php55-xsl
pkgdesc = xsl module for php55
depends = php55-xml=5.5.38
+ depends = php55-dom=5.5.38
depends = libxslt
pkgname = php55-xmlreader
@@ -355,7 +361,6 @@ pkgname = php55-recode
pkgname = php55-mbstring
pkgdesc = mbstring module for php55
depends = php55=5.5.38
- depends = oniguruma
pkgname = php55-pspell
pkgdesc = pspell module for php55
@@ -366,6 +371,11 @@ pkgname = php55-enchant
pkgdesc = enchant module for php55
depends = php55=5.5.38
depends = enchant
+ depends = libvoikko
+ depends = hspell
+ depends = hunspell
+ depends = nuspell
+ depends = aspell
pkgname = php55-intl
pkgdesc = intl module for php55
diff --git a/PKGBUILD b/PKGBUILD
index 5bbabc2f4dd5..4f7b7388ee98 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
###############################################################################
# Generated by arch-phpbs: https://github.com/lamskoy/arch-phpbs
#
-# My packages on AUR: php81 php72 php55 php54
+# My packages on AUR: php81 php74 php72 php55 php54
# Co-maintaining on AUR: php73
#
# Thanks to:
#
+# AUR php74 Co-maintainer: Tomasz Gruszka <tompear79@gmail.com>
# AUR php73 Co-maintainer: Matt Harrison <matt@harrison.us.com>
# AUR php73 Contirubutor: Pierre Schmitz <pierre@archlinux.de>
# AUR php55 Original maintainer: Raphaƫl Doursenaud <rdoursenaud@gmail.com>
@@ -13,7 +14,7 @@
_phpbase="55"
_suffix=""
pkgver="5.5.38"
-pkgrel="10"
+pkgrel="11"
pkgbase="php55"
pkgdesc="PHP 5.5.38 compiled as to not conflict with mainline php"
_cppflags=" -DU_USING_ICU_NAMESPACE=1 -DOPENSSL_NO_SSL3=1 -DOPENSSL_NO_SSL2=1 -DU_DEFINE_FALSE_AND_TRUE=1 "
@@ -188,6 +189,11 @@ makedepends=(
"recode"
"aspell"
"enchant"
+ "libvoikko"
+ "hspell"
+ "hunspell"
+ "nuspell"
+ "aspell"
"icu"
"curl"
"net-snmp"
@@ -275,6 +281,15 @@ _ext_depends_sqlite=(
"sqlite"
"php55-pdo=5.5.38"
)
+_ext_depends_mbstring=(
+ "php55=5.5.38"
+)
+_ext_depends_openssl=(
+ "php55=5.5.38"
+ "krb5"
+ "e2fsprogs"
+ "openssl-1.0"
+)
_phpconfig="\
--prefix=/usr \
--sbindir=/usr/bin \
@@ -463,6 +478,7 @@ prepare() {
fi
rm -f tests/output/stream_isatty_*.phpt
rm -f Zend/tests/arginfo_zpp_mismatch*.phpt
+ rm -f Zend/tests/bug79919.phpt
popd
}
@@ -647,7 +663,6 @@ build() {
check() {
pushd "build-cli"
# Check if sendmail was configured correctly (FS#47600)
- sapi/cli/php -n -r 'echo ini_get("sendmail_path");' | grep -q $(which sendmail)
export REPORT_EXIT_STATUS=1
export NO_INTERACTION=1
export SKIP_ONLINE_TESTS=1
@@ -1021,12 +1036,7 @@ package_php55-pecl() {
# OpenSSL
package_php55-openssl() {
pkgdesc="OpenSSL module for ${pkgbase}"
- depends=("${pkgbase}=${pkgver}" "krb5" 'e2fsprogs')
- if ((_build_openssl_v10_patch)); then
- depends+=("openssl-1.0")
- else
- depends+=("openssl")
- fi
+ depends=("${_ext_depends_openssl[@]}")
_install_module openssl
}
@@ -1048,10 +1058,7 @@ package_php55-pdo() {
# mbstring
package_php55-mbstring() {
pkgdesc="mbstring module for ${pkgbase}"
- depends=("${pkgbase}=${pkgver}")
- if ((_phpbase >= 74)); then
- depends+=('oniguruma')
- fi
+ depends=("${_ext_depends_mbstring[@]}")
_install_module mbstring
}
@@ -1115,7 +1122,7 @@ package_php55-tidy() {
# XSL
package_php55-xsl() {
pkgdesc="xsl module for ${pkgbase}"
- depends=("php${_phpbase}-xml${_suffix}=${pkgver}")
+ depends=("php${_phpbase}-xml${_suffix}=${pkgver}" "php${_phpbase}-dom${_suffix}=${pkgver}")
depends+=('libxslt')
_install_module xsl
}
@@ -1288,7 +1295,7 @@ package_php55-gmp() {
# Enchant
package_php55-enchant() {
pkgdesc="enchant module for ${pkgbase}"
- depends=("${pkgbase}=${pkgver}" 'enchant')
+ depends=("${pkgbase}=${pkgver}" 'enchant' 'libvoikko' 'hspell' 'hunspell' 'nuspell' 'aspell')
_install_module enchant
}