summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortjbp2016-04-10 23:01:23 +0100
committertjbp2016-04-10 23:01:23 +0100
commit7491403ea1ca15e357ea6baaefbf436e37eef2cd (patch)
tree6b0b7f426190196b0394f6c444d2d3942b34a6b0
downloadaur-7491403ea1ca15e357ea6baaefbf436e37eef2cd.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD53
-rw-r--r--php56.patch11
-rw-r--r--phpunit56.patch8
4 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ced44f8533f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Apr 10 22:01:01 UTC 2016
+pkgbase = php-composer56
+ pkgdesc = Dependency Manager for PHP 5.6
+ pkgver = 1.0.0
+ pkgrel = 1
+ epoch = 1
+ url = https://getcomposer.org/
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = php56
+ source = php-composer56::git+https://github.com/composer/composer.git#tag=1.0.0
+ source = php-composer56-1.0.0.phar::https://getcomposer.org/download/1.0.0/composer.phar
+ sha256sums = SKIP
+ sha256sums = 1acc000cf23bd9d19e1590c2edeb44fb915f88d85f1798925ec989c601db0bd6
+
+pkgname = php-composer56
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc1d709061b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: tjbp (archlinux@tjbp.net)
+# Contributor: Pierre Schmitz <pierre@archlinux.de>
+
+pkgname=php-composer56
+epoch=1
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Dependency Manager for PHP 5.6"
+arch=('any')
+license=('MIT')
+url='https://getcomposer.org/'
+depends=('php56')
+makedepends=('git')
+source=(
+ "${pkgname}::git+https://github.com/composer/composer.git#tag=${pkgver}"
+ "${pkgname}-${pkgver}.phar::https://getcomposer.org/download/${pkgver}/composer.phar"
+)
+sha256sums=(
+ 'SKIP'
+ '1acc000cf23bd9d19e1590c2edeb44fb915f88d85f1798925ec989c601db0bd6'
+)
+
+prepare() {
+ cd ${srcdir}/${pkgname}
+
+ php56 ${srcdir}/${pkgname}-${pkgver}.phar -n install --no-dev
+}
+
+build() {
+ cd ${srcdir}/${pkgname}
+
+ patch -p0 < ../../php56.patch
+
+ php56 -d phar.readonly=Off bin/compile
+}
+
+check() {
+ cd ${srcdir}/${pkgname}
+
+ # Install the dev dependencies to run the unit tests
+ bin/composer -n install
+
+ patch -p0 < ../../phpunit56.patch
+
+ vendor/bin/phpunit
+}
+
+package() {
+ cd ${srcdir}/${pkgname}
+
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm755 composer.phar ${pkgdir}/usr/bin/composer
+}
diff --git a/php56.patch b/php56.patch
new file mode 100644
index 000000000000..b1d6252560ef
--- /dev/null
+++ b/php56.patch
@@ -0,0 +1,11 @@
+--- php-composer56/src/Composer/Compiler.php 2016-04-10 22:22:14.056406238 +0100
++++ php-composer56/src/Composer/Compiler.php 2016-04-10 22:39:13.935566040 +0100
+@@ -224,7 +224,7 @@
+ private function getStub()
+ {
+ $stub = <<<'EOF'
+-#!/usr/bin/env php
++#!/usr/bin/env php56
+ <?php
+ /*
+ * This file is part of Composer.
diff --git a/phpunit56.patch b/phpunit56.patch
new file mode 100644
index 000000000000..58793c705a02
--- /dev/null
+++ b/phpunit56.patch
@@ -0,0 +1,8 @@
+--- vendor/phpunit/phpunit/phpunit 2016-02-11 14:56:33.000000000 +0000
++++ vendor/phpunit/phpunit/phpunit 2016-04-10 22:52:38.205971643 +0100
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env php
++#!/usr/bin/env php56
+ <?php
+ /*
+ * This file is part of PHPUnit.