summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Saliés Brum2016-06-02 17:07:53 -0400
committerLucas Saliés Brum2016-06-02 17:07:53 -0400
commit39723a566c9f24efc0cbdde1758b7fe0d8dfe972 (patch)
tree31d624939cc034a11c1dac396ea3f5fb452d5e85
downloadaur-39723a566c9f24efc0cbdde1758b7fe0d8dfe972.tar.gz
Commit inicial...
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc454af4c258
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = php7-ioncube_loader
+ pkgdesc = Loader for PHP files encoded with ionCube PHP Encoder
+ pkgver = beta4
+ pkgrel = 1
+ url = http://www.ioncube.com/
+ arch = i686
+ arch = x86_64
+ license = CUSTOM
+ depends = php
+ conflicts = php-ioncube_loader
+ backup = etc/php/conf.d/00-ioncube_loader.ini
+ source_i686 = php7-linux-x86-beta4.tgz::https://www.ioncube.com/php7-linux-x86-beta4.tgz
+ sha256sums_i686 = 83421468fc9300debd9092e3c9b0f20eee8143d5dd0cfd4fc956ae1a977a7e47
+ source_x86_64 = php7-linux-x86-64-beta4.tgz::https://www.ioncube.com/php7-linux-x86-64-beta4.tgz
+ sha256sums_x86_64 = d4806f817fd4b3455364feee4b35ea34eb53ebcc4f5f425500a1813f9e457f64
+
+pkgname = php7-ioncube_loader
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa292313f657
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Lucas Saliés Brum <lucas@archlinux.com.br>
+
+pkgname=php7-ioncube_loader
+pkgver=beta4
+pkgrel=1
+pkgdesc="Loader for PHP files encoded with ionCube PHP Encoder"
+arch=(i686 x86_64)
+url="http://www.ioncube.com/"
+license=('CUSTOM')
+depends=(php)
+conflicts=('php-ioncube_loader')
+backup=(etc/php/conf.d/00-ioncube_loader.ini)
+
+source_i686=(php7-linux-x86-$pkgver.tgz::https://www.ioncube.com/php7-linux-x86-beta4.tgz)
+source_x86_64=(php7-linux-x86-64-$pkgver.tgz::https://www.ioncube.com/php7-linux-x86-64-beta4.tgz)
+
+sha256sums_i686=('83421468fc9300debd9092e3c9b0f20eee8143d5dd0cfd4fc956ae1a977a7e47')
+sha256sums_x86_64=('d4806f817fd4b3455364feee4b35ea34eb53ebcc4f5f425500a1813f9e457f64')
+
+package() {
+ cd "$srcdir"/ioncube
+ install -dm0755 "$pkgdir"/etc/php/conf.d
+ install -Dm0755 ioncube_loader_lin_x86-64_7.0b4.so "$pkgdir"/usr/lib/php/modules/ioncube_loader.so
+ echo "zend_extension = /usr/lib/php/modules/ioncube_loader.so" > "$pkgdir"/etc/php/conf.d/00-ioncube_loader.ini
+ install -Dm0644 README_PHP7_X86_64_BETA "$pkgdir"/usr/share/doc/$pkgname/README.txt
+}