summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Rynn2017-05-25 23:12:35 +1000
committerMichael Rynn2017-05-25 23:12:35 +1000
commit0ab8aed1c8bb1b5b419b11a5ef8c5d5b0b4b1a25 (patch)
tree5f8b09522c4791cf1f42be552c0045b6886bc325
parentbfa531a2eee83704c84c5bb8f175d46a545631d7 (diff)
downloadaur-0ab8aed1c8bb1b5b419b11a5ef8c5d5b0b4b1a25.tar.gz
bug fixes and good for SSL 1.1.0
-rw-r--r--.SRCINFO46
-rw-r--r--PKGBUILD25
2 files changed, 27 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe9af1808d4..019330e0dd5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = php70
pkgdesc = PHP scripting language package for stable release of 7.0 series
- pkgver = 7.0.18
- pkgrel = 3
+ pkgver = 7.0.19
+ pkgrel = 1
url = http://www.php.net
arch = i686
arch = x86_64
@@ -13,7 +13,6 @@ pkgbase = php70
makedepends = gd
makedepends = gmp
makedepends = icu
- makedepends = openssl-1.0
makedepends = libmcrypt
makedepends = libxslt
makedepends = libzip
@@ -28,8 +27,8 @@ pkgbase = php70
makedepends = freetds
makedepends = pcre
makedepends = c-client
- source = https://php.net/distributions/php-7.0.18.tar.xz
- source = https://php.net/distributions/php-7.0.18.tar.xz.asc
+ source = https://php.net/distributions/php-7.0.19.tar.xz
+ source = https://php.net/distributions/php-7.0.19.tar.xz.asc
source = apache.patch
source = apache.conf
source = php-fpm.patch
@@ -37,7 +36,7 @@ pkgbase = php70
source = php.ini.patch
validpgpkeys = 1A4E8B7277C42E53DBA9C7B9BCAA30EA9C0D5763
validpgpkeys = 6E4F6AB321FDC07F2C332E3AC2BF0BC433CFC8B3
- sha256sums = 679cffcdf2495dee5ab89bda595e678a1096136678b3a1d08f1f57ba347c234d
+ sha256sums = 640e5e3377d15a6d19adce2b94a9d876eeddabdb862d154a5e347987f4225ef6
sha256sums = SKIP
sha256sums = 819f05d2fd5a75c96e93c863517ca77dbd021a1224dc2d8096f758fb2937df6a
sha256sums = df075b89484eb3a08402788580de16d23123f95541b2e9aed8d928105de9b874
@@ -51,8 +50,7 @@ pkgname = php70
depends = curl
depends = libzip
depends = pcre
- depends = openssl-1.0
- provides = php=7.0.18
+ provides = php=7.0.19
conflicts = php70-ldap
replaces = php70-ldap
backup = etc/${pkgbase}/php.ini
@@ -60,7 +58,7 @@ pkgname = php70
pkgname = php70-cgi
pkgdesc = CGI and FCGI SAPI for PHP
depends = php70
- provides = php-cgi=7.0.18
+ provides = php-cgi=7.0.19
pkgname = php70-apache
pkgdesc = Apache SAPI for PHP
@@ -78,90 +76,90 @@ pkgname = php70-fpm
pkgname = php70-embed
pkgdesc = Embedded PHP SAPI library
depends = php70
- provides = php70-embed=7.0.18
+ provides = php70-embed=7.0.19
options = !emptydirs
pkgname = php70-phpdbg
pkgdesc = Interactive PHP debugger
depends = php70
- provides = php70-phpdbg=7.0.18
+ provides = php70-phpdbg=7.0.19
options = !emptydirs
pkgname = php70-dblib
pkgdesc = dblib module for PHP
depends = php70
- provides = php70-dblib=7.0.18
+ provides = php70-dblib=7.0.19
pkgname = php70-enchant
pkgdesc = enchant module for PHP
depends = php70
depends = enchant
- provides = php70-enchant=7.0.18
+ provides = php70-enchant=7.0.19
pkgname = php70-gd
pkgdesc = gd module for PHP
depends = php70
depends = gd
- provides = php70-gd=7.0.18
+ provides = php70-gd=7.0.19
pkgname = php70-imap
pkgdesc = imap module for PHP
depends = php70
depends = c-client
- provides = php70-imap=7.0.18
+ provides = php70-imap=7.0.19
pkgname = php70-intl
pkgdesc = intl module for PHP
depends = php70
depends = icu
- provides = php70-intl=7.0.18
+ provides = php70-intl=7.0.19
pkgname = php70-mcrypt
pkgdesc = mcrypt module for PHP
depends = php70
depends = libmcrypt
depends = libltdl
- provides = php70-mcrypt=7.0.18
+ provides = php70-mcrypt=7.0.19
pkgname = php70-odbc
pkgdesc = ODBC modules for PHP
depends = php70
depends = unixodbc
- provides = php70-odbc=7.0.18
+ provides = php70-odbc=7.0.19
pkgname = php70-pgsql
pkgdesc = PostgreSQL modules for PHP
depends = php70
depends = postgresql-libs
- provides = php70-pgsql=7.0.18
+ provides = php70-pgsql=7.0.19
pkgname = php70-pspell
pkgdesc = pspell module for PHP
depends = php70
depends = aspell
- provides = php70-pspell=7.0.18
+ provides = php70-pspell=7.0.19
pkgname = php70-snmp
pkgdesc = snmp module for PHP
depends = php70
depends = net-snmp
- provides = php70-snmp=7.0.18
+ provides = php70-snmp=7.0.19
pkgname = php70-sqlite
pkgdesc = sqlite module for PHP
depends = php70
depends = sqlite
- provides = php70-sqlite=7.0.18
+ provides = php70-sqlite=7.0.19
pkgname = php70-tidy
pkgdesc = tidy module for PHP
depends = php70
depends = tidyhtml
- provides = php70-tidy=7.0.18
+ provides = php70-tidy=7.0.19
pkgname = php70-xsl
pkgdesc = xsl module for PHP
depends = php70
depends = libxslt
- provides = php70-xsl=7.0.18
+ provides = php70-xsl=7.0.19
diff --git a/PKGBUILD b/PKGBUILD
index e77ea2b7bdb..b1c337056be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,8 +27,8 @@ pkgname=("${pkgbase}"
"${pkgbase}-sqlite"
"${pkgbase}-tidy"
"${pkgbase}-xsl")
-pkgver=7.0.18
-pkgrel=3
+pkgver=7.0.19
+pkgrel=1
pkgdesc="PHP scripting language package for stable release of 7.0 series"
arch=('i686' 'x86_64')
license=('PHP')
@@ -36,14 +36,14 @@ license=('PHP')
url='http://www.php.net'
makedepends=('apache' 'aspell' 'db' 'enchant' 'gd' 'gmp' 'icu'
- 'openssl-1.0' 'libmcrypt' 'libxslt' 'libzip' 'net-snmp'
+ 'libmcrypt' 'libxslt' 'libzip' 'net-snmp'
'postgresql-libs' 'sqlite' 'systemd' 'tidy' 'unixodbc' 'curl'
'libtool' 'freetds' 'pcre' 'c-client')
source=("https://php.net/distributions/${_pkgbase}-${pkgver}.tar.xz"{,.asc}
'apache.patch' 'apache.conf' 'php-fpm.patch' 'php-fpm.tmpfiles' 'php.ini.patch'
)
-sha256sums=('679cffcdf2495dee5ab89bda595e678a1096136678b3a1d08f1f57ba347c234d'
+sha256sums=('640e5e3377d15a6d19adce2b94a9d876eeddabdb862d154a5e347987f4225ef6'
'SKIP'
'819f05d2fd5a75c96e93c863517ca77dbd021a1224dc2d8096f758fb2937df6a'
'df075b89484eb3a08402788580de16d23123f95541b2e9aed8d928105de9b874'
@@ -140,18 +140,6 @@ build() {
--enable-pcntl \
"
- # PHP 7.0 is unlikely to become compatible with openssl >= 1.1
- # changed build environment
- local _sav_PKG_CONFIG_PATH=$PKG_CONFIG_PATH
- local _sav_CFLAGS=$CFLAGS
- local _sav_LDFLAGS=$LDFLAGS
-
- export PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig
- CFLAGS+=" -I/usr/include/openssl-1.0"
- LDFLAGS+=" -L/usr/lib/openssl-1.0 -lssl"
- export CFLAGS
- export LDFLAGS
-
EXTENSION_DIR=/usr/lib/${pkgbase}/modules
export EXTENSION_DIR
@@ -191,15 +179,12 @@ build() {
make
cd ../../
- export PKG_CONFIG_PATH=$_sav_PKG_CONFIG_PATH
- export CFLAGS=$_sav_CFLAGS
- export LDFLAGS=$_sav_LDFLAGS
}
package_php70() {
pkgdesc='A general-purpose scripting language that is especially suited to web development'
- depends=('libxml2' 'curl' 'libzip' 'pcre' 'openssl-1.0')
+ depends=('libxml2' 'curl' 'libzip' 'pcre')
replaces=('php70-ldap')
conflicts=('php70-ldap')
provides=("${_pkgbase}=$pkgver")