summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Gathoye2018-12-23 20:14:32 +0100
committerWilliam Gathoye2018-12-23 20:53:32 +0100
commit97af67ba03319007b1c7db11903b15e0c2c0fe6c (patch)
tree0040c40cb66771a1853d79e56d2e9190ed6c1a94
parent5d087dc2def809b71f53a76c5e9feb4277119ba8 (diff)
downloadaur-97af67ba03319007b1c7db11903b15e0c2c0fe6c.tar.gz
Reenable tests
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD16
2 files changed, 16 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 628863e3b50f..1329375c0cd9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = php70
pkgdesc = A general-purpose scripting language that is especially suited to web development (old stable 7.0 series)
pkgver = 7.0.33
- pkgrel = 1
+ pkgrel = 2
url = http://www.php.net
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index cb919a79be2a..b7444e8e8134 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -32,7 +32,7 @@ pkgname=(
"${pkgbase}-xsl"
)
pkgver=7.0.33
-pkgrel=1
+pkgrel=2
pkgdesc='A general-purpose scripting language that is especially suited to web development (old stable 7.0 series)'
arch=('i686' 'x86_64')
url='http://www.php.net'
@@ -215,6 +215,20 @@ build() {
cd ../
}
+check() {
+ cd ${srcdir}/${_pkgbase}-${pkgver}
+
+ # Check if sendmail was configured correctly (FS#47600)
+ ${srcdir}/build/sapi/cli/php -n -r 'echo ini_get("sendmail_path");' | grep -q '/usr/bin/sendmail'
+
+ export REPORT_EXIT_STATUS=1
+ export NO_INTERACTION=1
+ export SKIP_ONLINE_TESTS=1
+ export SKIP_SLOW_TESTS=1
+
+ ${srcdir}/build/sapi/cli/php -n run-tests.php -n -P {tests,Zend}
+}
+
package_php70() {
pkgdesc='A general-purpose scripting language that is especially suited to web development'
depends=('libxml2' 'curl' 'libzip' 'pcre')