summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene Lamskoy2022-11-05 19:58:11 +0200
committerEugene Lamskoy2022-11-05 19:58:11 +0200
commita9bcf82526fbc8ab231e334b2b26d2d6a3400045 (patch)
tree0c2a9477bd1ee1ad2c3c8cb7f51a2e237231c5fe
parent0dc0e50a38c993a8aba85244f98c2246a1c89233 (diff)
downloadaur-a9bcf82526fbc8ab231e334b2b26d2d6a3400045.tar.gz
Fixed build against openssl 3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
-rw-r--r--openssl-sslv3-consts.patch12
3 files changed, 22 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a85aaebcc469..df7becad153b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
-# Generated by makepkg 6.0.1
-# Fri Feb 18 11:02:19 UTC 2022
+# Generated by makepkg 6.0.2
+# Sat Nov 5 17:54:35 UTC 2022
pkgbase = php70
pkgdesc = PHP 7.0.33 compiled as to not conflict with mainline php
pkgver = 7.0.33
- pkgrel = 9
+ pkgrel = 10
url = http://www.php.net
arch = x86_64
license = PHP
@@ -70,6 +70,7 @@ pkgbase = php70
source = php-apache.conf
source = https://php.net/distributions/php-7.0.33.tar.xz
source = php55-phar-names.patch
+ source = openssl-sslv3-consts.patch
source = fpm-numeric-uid-gid.patch
source = fpm-reload-sighup.patch
source = mysql-socket-php5.3.patch
@@ -88,6 +89,7 @@ pkgbase = php70
sha256sums = 6d0ad9becb5470ce8e5929d7d45660b0f32579038978496317544c5310281a91
sha256sums = ab8c5be6e32b1f8d032909dedaaaa4bbb1a209e519abb01a52ce3914f9a13d96
sha256sums = 70e3cc00d954fa2b466a0e8f356c68bbb1e92b36304deaffd34c53cb6ae5e979
+ sha256sums = aecd8dff7022e956718407a5b98dec19acdceef08b0a58e7266b483bc3845de6
sha256sums = d175f0c14fdb22855090c93f76e18f04320d7bf15afc057ffde947f9bb361242
sha256sums = f5ae925036744a5e88cea2698879aea0498e1e23aee7801923d90f16be383908
sha256sums = 12f4e3aeab72e7d24221c07b64106c496c2e300518682bd301351dc9fa6ab3cf
diff --git a/PKGBUILD b/PKGBUILD
index 8631959fe459..2caf2cd2015e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@
_phpbase="70"
_suffix=""
pkgver="7.0.33"
-pkgrel="9"
+pkgrel="10"
pkgbase="php70"
pkgdesc="PHP 7.0.33 compiled as to not conflict with mainline php"
_cppflags=" -DU_USING_ICU_NAMESPACE=1 -DU_DEFINE_FALSE_AND_TRUE=1 "
@@ -133,6 +133,7 @@ source=(
"php-apache.conf"
"https://php.net/distributions/php-${pkgver}.tar.xz"
"php55-phar-names.patch"
+ "openssl-sslv3-consts.patch"
"fpm-numeric-uid-gid.patch"
"fpm-reload-sighup.patch"
"mysql-socket-php5.3.patch"
@@ -210,6 +211,7 @@ arch=(
)
_patches=(
"php55-phar-names.patch"
+ "openssl-sslv3-consts.patch"
"fpm-numeric-uid-gid.patch"
"fpm-reload-sighup.patch"
"mysql-socket-php5.3.patch"
@@ -302,7 +304,7 @@ _phpconfig="\
--libdir=/usr/lib/php${_phpbase}${_suffix} \
--datadir=/usr/share/php${_phpbase}${_suffix} \
--program-suffix=${_phpbase}${_suffix} \
- --with-config-file-scan-dir=/${_build_conf_d}
+ --with-config-file-scan-dir=/${_build_conf_d} \
--enable-filter \
--with-pear \
--enable-session \
@@ -1544,6 +1546,7 @@ sha256sums=('e6b8530d747000eebb0089249ec70a3b14add7b501337046700544883f62b17b'
'6d0ad9becb5470ce8e5929d7d45660b0f32579038978496317544c5310281a91'
'ab8c5be6e32b1f8d032909dedaaaa4bbb1a209e519abb01a52ce3914f9a13d96'
'70e3cc00d954fa2b466a0e8f356c68bbb1e92b36304deaffd34c53cb6ae5e979'
+ 'aecd8dff7022e956718407a5b98dec19acdceef08b0a58e7266b483bc3845de6'
'd175f0c14fdb22855090c93f76e18f04320d7bf15afc057ffde947f9bb361242'
'f5ae925036744a5e88cea2698879aea0498e1e23aee7801923d90f16be383908'
'12f4e3aeab72e7d24221c07b64106c496c2e300518682bd301351dc9fa6ab3cf'
diff --git a/openssl-sslv3-consts.patch b/openssl-sslv3-consts.patch
new file mode 100644
index 000000000000..f8075216683b
--- /dev/null
+++ b/openssl-sslv3-consts.patch
@@ -0,0 +1,12 @@
+--- a/ext/openssl/openssl.c
++++ b/ext/openssl/openssl.c
+@@ -1482,7 +1482,9 @@
+ REGISTER_LONG_CONSTANT("PKCS7_NOSIGS", PKCS7_NOSIGS, CONST_CS|CONST_PERSISTENT);
+
+ REGISTER_LONG_CONSTANT("OPENSSL_PKCS1_PADDING", RSA_PKCS1_PADDING, CONST_CS|CONST_PERSISTENT);
++#ifdef RSA_SSLV23_PADDING
+ REGISTER_LONG_CONSTANT("OPENSSL_SSLV23_PADDING", RSA_SSLV23_PADDING, CONST_CS|CONST_PERSISTENT);
++#endif
+ REGISTER_LONG_CONSTANT("OPENSSL_NO_PADDING", RSA_NO_PADDING, CONST_CS|CONST_PERSISTENT);
+ REGISTER_LONG_CONSTANT("OPENSSL_PKCS1_OAEP_PADDING", RSA_PKCS1_OAEP_PADDING, CONST_CS|CONST_PERSISTENT);
+