summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorris Jobke2015-06-08 14:36:56 +0200
committerMorris Jobke2015-06-08 14:36:56 +0200
commit7180d852b884c0e51d12ab35a39e3500d6d63ce2 (patch)
treefe4eba3fdbac1e4f35eaa288e021343249415a43
downloadaur-7180d852b884c0e51d12ab35a39e3500d6d63ce2.tar.gz
php-blackfire 0.23.0
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD20
-rw-r--r--blackfire.ini16
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3168c97800f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = php-blackfire
+ pkgdesc = Blackfire Profiler - PHP extension
+ pkgver = 0.23.0
+ pkgrel = 1
+ url = https://blackfire.io
+ arch = i686
+ arch = x86_64
+ license = custom
+ backup = etc/php/conf.d/blackfire.ini
+ source = blackfire.ini
+ md5sums = 4768c8ab9fe7e6d690dfafbe8adfc56d
+ source_i686 = http://packages.blackfire.io/binaries/blackfire-php/0.23.0/blackfire-php-linux_i386-php-56.so
+ md5sums_i686 = d57a70ff481b75caba98ca01eab25393
+ source_x86_64 = http://packages.blackfire.io/binaries/blackfire-php/0.23.0/blackfire-php-linux_amd64-php-56.so
+ md5sums_x86_64 = 7ff9b2a829ea5c62256fa5149de38af4
+
+pkgname = php-blackfire
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e1feb0d18939
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Morris Jobke <hey AT morrisjobke DOT de>
+pkgname=php-blackfire
+pkgver=0.23.0
+pkgrel=1
+pkgdesc='Blackfire Profiler - PHP extension'
+arch=('i686' 'x86_64')
+url='https://blackfire.io'
+license='custom'
+backup=('etc/php/conf.d/blackfire.ini')
+source=('blackfire.ini')
+source_i686=("http://packages.blackfire.io/binaries/blackfire-php/$pkgver/blackfire-php-linux_i386-php-56.so")
+source_x86_64=("http://packages.blackfire.io/binaries/blackfire-php/$pkgver/blackfire-php-linux_amd64-php-56.so")
+md5sums=('4768c8ab9fe7e6d690dfafbe8adfc56d')
+md5sums_i686=('d57a70ff481b75caba98ca01eab25393')
+md5sums_x86_64=('7ff9b2a829ea5c62256fa5149de38af4')
+
+package(){
+ install -Dm 644 blackfire.ini ${pkgdir}/etc/php/conf.d/blackfire.ini
+ install -Dm 755 blackfire-php-linux_* ${pkgdir}/usr/lib/php/modules/blackfire.so
+}
diff --git a/blackfire.ini b/blackfire.ini
new file mode 100644
index 000000000000..44bb4df80144
--- /dev/null
+++ b/blackfire.ini
@@ -0,0 +1,16 @@
+[blackfire]
+;extension="/usr/lib/php/modules/blackfire.so"
+
+blackfire.agent_socket = unix:///var/run/blackfire/agent.sock
+
+blackfire.agent_timeout = 0.25
+
+; Log verbosity level (4: debug, 3: info, 2: warning, 1: error)
+;blackfire.log_level = 1
+
+; Log file on Linux systems
+blackfire.log_file = /tmp/blackfire.log
+
+;blackfire.server_id =
+
+;blackfire.server_token =